Jump to content
Kahless

Core v21 280mm radiator issue

Recommended Posts

I built a system into a Core V21 case a while back.  The specs say a 280mm radiator will fit in the top of the case in the default config.  I attempted to put a Corsair h115i GTX into it but there isn't a mounting slot for the rails to go to that width.  I tried every possible config to get the rails to fit that width.  It's like its missing a slot for the rails to go into for a 280mm radiator.  Ultimately they are stuck into the wrong slots so the radiator is going in a a bit of an angle and looks terrible.  Consequently I can't add any fans on the second set of rails at the top of how it's sitting in place.  Just wondering if I got a defective case or something.  As there seems to be no normal way to mount a 280mm unit at the top.  Been living with it like this for a couple months and I'm getting fed up with it.  Any ideas on what is going wrong here?

Share this post


Link to post
Share on other sites

Yes, the documentation does say so, it's why I bought this particular case.  However, it's impossible to move them to that particular width because the holes to insert the rails into for 280mm are completely missing on one side of the case.  So I have the rails inserted into the correct holes on one side and on the other side that it's missing I have it into the 240mm width holes which makes the radiator sit at an angle.  And it prevents me from mounting a 140mm fan on the second set of rails since the radiator is going at an angle.

 

Share this post


Link to post
Share on other sites

Kahless,

The Core V21 does support 280 sized radiator on the top.

I mocked one up and took some picture to show, you just need to offset the rails to convert from 120 >> 140 spacing.

See where the rails need to go on one side for the radiator to fit.

1.JPG

 

 

2.JPG

Share this post


Link to post
Share on other sites

Thanks for responding.

I attached a picture.  Its funny, about 3 hours before you responded I took matters into my own hands and drilled two holes into the case to create a new attachment point so the radiator didn't sit at a crazy angle.  I guess I really wasn't going to completely dismantle my computer just to RMA a case I only paid $45 for on Amazon.

In my pic I am showing the one side of the case has the correct mounting points.  On the other side of the case a slot is missing.  I spent literally hours trying all the slots and there was no possible way that that I missed a mounting point.  There is literally some sort of defect that whatever assembly line cut these things missed a slot.  The way the radiator is mounted in the pic posted above is impossible on my case 

 

Radiator.jpg

Share this post


Link to post
Share on other sites

Hi,

Sorry for all the troubles, if I can help any let me know.

Could you help to get me picture of the missing slots? Maybe from the front so you dont have to take out the rad?

From your picture those slots on the left are under the frame, you cant see them from the top :)That top punch out is only on the other side with the clips. Like you show.The punches could have been missed, but I did want to confirm this was the case.

Try to take a few pics so I can see where on the case you are showing and the missing punches for the slots that the brackets go into on the front side under the top frame.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...