Jump to content

Premium X1 RGB keyboard Owner's Club


Jag007
 Share

Recommended Posts

When you Debug via Visual Studio some of the output is:

libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
kk_time_function
init_lib_usb()
write_log_int() "log_init_lib_usb" "log_init_lib_usb_start"
woooo keyboard  32902 5558
woooo keyboard  6048 784
woooo keyboard  9802 12307
woooo keyboard  6720 257
woooo keyboard  2522 63012
woooo keyboard  1103 45320
woooo keyboard  9390 16656
woooo keyboard  1118 1817
woooo keyboard  32902 41263
Cannot open device
write_log_int() "log_init_lib_usb" "log_init_lib_usb_not_found"
return_usb_drive_connect_function()
'X1 RGB.exe' (Win32): Loaded 'C:\Windows\SysWOW64\rasadhlp.dll'. Cannot find or open the PDB file.
'X1 RGB.exe' (Win32): Loaded 'C:\Windows\SysWOW64\winusb.dll'. Cannot find or open the PDB file.
'X1 RGB.exe' (Win32): Loaded 'C:\Windows\SysWOW64\FWPUCLNT.DLL'. Cannot find or open the PDB file.
'X1 RGB.exe' (Win32): Loaded 'C:\Windows\SysWOW64\TextInputFramework.dll'. Cannot find or open the PDB file.
'X1 RGB.exe' (Win32): Loaded 'C:\Windows\SysWOW64\CoreMessaging.dll'. Cannot find or open the PDB file.
'X1 RGB.exe' (Win32): Loaded 'C:\Windows\SysWOW64\CoreUIComponents.dll'. Cannot find or open the PDB file.
'X1 RGB.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ntmarta.dll'. Cannot find or open the PDB file.
finishedSlot----------Start
"\t\r\n\t{\"Result_Code\":\"002\",\"Data\":{\"version\":\"V1.9.0\",\"note\":\" 1. Add Portuguese And Spanish Languages\"}}"
json_obj: QJsonObject({"Data":{"note":" 1. Add Portuguese And Spanish Languages","version":"V1.9.0"},"Result_Code":"002"})
Data: ""
------------------------
version: "V1.9.0"
---------------------------------
V0: 1 , V1: 9 , V2: 0
oldV0: 1 , oldV1: 9 , oldV2: 0
---------------------------------
33333
finishedSlot----------End
main_mouseMoveEvent


Don't know if it helps ?

Link to comment
Share on other sites

  • 2 weeks later...

Hello,

Although I have not faced this mentioned issue yet. (Have not checked my win 10 update version) But I am 100% sure people should stop blaming windows 10 or its updates for this issue. This issue is software issue from Thermaltake's side and they should fix these kinds of issues in their future software updates. I remember in previous windows update also X1 software crashes often. This software is somewhat buggy and has stability issue from beginning and WIN 10 has nothing to do with this. Its Tt's job to make software stable and compatible with OS and its updates.

Link to comment
Share on other sites

I recently bought the x1 rgb as my first keyboard, I love it. However this #### issue is frustrating the #### out of me and I'm thinking of returning the keyboard if this keeps up, whenever I open the program it tells me to plug in a thermaltake device, however I have the keyboard plugged in always.

Link to comment
Share on other sites

After emails with Thermaltake, I can confirm that the drivers are not supported with Windows 10 ver. 1809, however they will be releasing a fix to address this issue, however there is no ETA as yet, sit tight.

image.thumb.png.c56401096d279505f6731a49b64ca788.png

I have attached a small snippet from the latest email they have sent me, which confirms it, hopefully they release it soon.

Thank you for reading and have a nice day or night! (depending when you read this)

-Cynaax

Link to comment
Share on other sites

@Cynaax , great help on this issue, Thanks !! Hope now people will either pause windows update (like me) to avoid this issue or will wait patiently for Tt to fix this issue with future software update. Hope to receive updated software real soon, also waiting anxiously for compatibility for Razer synapse 3 for Tt products, which was to happen  Q4 2018 as per announcement, but now delayed for "Around Q1 2019". Also wondering if this collaboration can add multilayer effects capability to this X1 premium keyboard. If this happens won't that be awesome guys? 

GUYS PLEASE READ INFO BY "Cynaax" BEFORE FORMATTING YOUR WINDOWS 10 AND REINSTALLING TT X1 SOFTWARE FOR "KEYBOARD NOT DETECTED ISSUE". :P

Link to comment
Share on other sites

I wasn't expecting the update today either, it actually surprised me when I read that lol, I'll quickly get the software booted up and updated, thank you everyone for your input to this issue, if it weren't for us all this issue wouldn't have been addressed.

Also no problem @Jag007

Again, a big thank you to everyone, I hope you all have a great day or night, depending on when you read this

-Cynaax

Link to comment
Share on other sites

  • 2 weeks later...

The software won't start properly after I install it. No matter it is X1 RGB Setup_V1.9.0 or X1 RGB Setup_V1.10.0

When I clicked the X1 RGB, the icon showed in task bar, but when I move the mouse to the icon, it disappear. I tried run the software in Windows Safe mode, same thing happened.

Anyone can help me please? Many thanks.

Link to comment
Share on other sites

11 hours ago, Jag007 said:

Hi,

Software crashes many times, I also many time try opening software 3-4 times before it actually opens and stay on screen. 

Thank you so much for you reply.

I tried what you told, no matter how many times I opened (20-30 at least), the app icon just disappear when I move the mouse to it. And I couldn't find the task from task management list. So frustrating. 

Link to comment
Share on other sites

  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...