Jump to content
Sign in to follow this  
General

HELP URGENT Tt THERON CANT CANGE PROFILES

Recommended Posts

Hi guys, I've just updated my mouse's firmware to v1.2 and now I can't switch between profiles. I tried switching profiles in the software too but it didn't either.

I also read some forums but noone seems to have the same problem.

 

Do you have any idea how to reset the firmware?

I couldn't find any earlier versions

Share this post


Link to post
Share on other sites

Hi General,

Did you download and install the latest AP too?

THERON AP V1.3

 

Thermaltake USA Customer Service

email: ttsupport@thermaltakeusa.com

Toll free: 1-800-988-1088 M-F 9:00AM ~ 5:30PM (P.S.T.)

yes i did sir, i tried 3 times reinstal still have 1 profile, profile 2 - profile 5 its not even working or cant be using, when i klik the button profil, its dsnt cange to profil 2, profile 3, profile 4, profile 5, its only profile 1.

Share this post


Link to post
Share on other sites
Guest Tt Josh

yes i did sir, i tried 3 times reinstal still have 1 profile, profile 2 - profile 5 its not even working or cant be using, when i klik the button profil, its dsnt cange to profil 2, profile 3, profile 4, profile 5, its only profile 1.

Hi General, We have escalated your issue to our Product Management team and they will update the firmware for you to update when it's ready.

We will keep you update when the firmware is ready to be installed.

Sorry for the inconvenience caused.

Share this post


Link to post
Share on other sites
Guest Tt Josh

yes i did sir, i tried 3 times reinstal still have 1 profile, profile 2 - profile 5 its not even working or cant be using, when i klik the button profil, its dsnt cange to profil 2, profile 3, profile 4, profile 5, its only profile 1.

Hi General, have been notified by the team that the updated firmware will be available to install by tomorrow. Make sure you have the new update installed and keep us updated!  ;)

Share this post


Link to post
Share on other sites

Hi General, have been notified by the team that the updated firmware will be available to install by tomorrow. Make sure you have the new update installed and keep us updated!  ;)

 

Hi josh,

 

I did download and instal new AP 1.3.1 but still only 1 profil i can use.  i was uninstal the older version and instal to the newer version it still didnt work. i did reset default too, but still didnt work, i think i just we just need firmware not AP update. but thanks for trying to help and update :) love u TT Esport.

Share this post


Link to post
Share on other sites
Guest Tt Josh

Hi josh,

 

I did download and instal new AP 1.3.1 but still only 1 profil i can use.  i was uninstal the older version and instal to the newer version it still didnt work. i did reset default too, but still didnt work, i think i just we just need firmware not AP update. but thanks for trying to help and update :) love u TT Esport.

Hey General,

 

Try to install this install this firmware : FIRMWARE

 

Hope this firmware helps!

 

Thanks for supporting us!  ;)

Share this post


Link to post
Share on other sites

Hey General,

 

Try to install this install this firmware : FIRMWARE

 

Hope this firmware helps!

 

Thanks for supporting us!  ;)

Hi Josh,

 

Thanks for the UPDATE Firmware, its working my bottom button, i can cange my profiles ( OSD showed UP in my monitor  ). 

Pic :http://imageshack.com/a/img537/4940/Rnplnj.jpg

Pic 2 :  http://imageshack.com/a/img673/4615/rl7w0f.jpg

 

but, still didnt working at all After i update firmware, my mouse stop working, then i read in forum n use "sensor_on_lift_off_tool_v1.0.0.1" 

i still cant use my mouse until i press profil button. and OSD showed : http://imageshack.com/a/img661/7399/o6wMwv.jpgAnd mouse working normally.

 

but after profile "P1" showed UP  i cant cange profil anymore. 

 

  • i tried reinstal AP from CD ( Many time )
  • I tried reinstal AP v1.3
  • i tried reinstal AP v1.3.1
  • i tried restart PC ( many time )
  • i tried reInstal firmware "tt esports theron firmware update tool v1.2" then instal Firmware from drobox u did upload.

Thanks josh n team for helping me :) i will be waiting for next updates

Share this post


Link to post
Share on other sites
Guest Tt Josh

Hi Josh,

 

Thanks for the UPDATE Firmware, its working my bottom button, i can cange my profiles ( OSD showed UP in my monitor  ). 

Pic :http://imageshack.com/a/img537/4940/Rnplnj.jpg

Pic 2 :  http://imageshack.com/a/img673/4615/rl7w0f.jpg

 

but, still didnt working at all After i update firmware, my mouse stop working, then i read in forum n use "sensor_on_lift_off_tool_v1.0.0.1" 

i still cant use my mouse until i press profil button. and OSD showed : http://imageshack.com/a/img661/7399/o6wMwv.jpgAnd mouse working normally.

 

but after profile "P1" showed UP  i cant cange profil anymore. 

 

  • i tried reinstal AP from CD ( Many time )
  • I tried reinstal AP v1.3
  • i tried reinstal AP v1.3.1
  • i tried restart PC ( many time )
  • i tried reInstal firmware "tt esports theron firmware update tool v1.2" then instal Firmware from drobox u did upload.

Thanks josh n team for helping me :) i will be waiting for next updates

 

Hey General,

 

Sorry for the late reply. We're having our weekend off  ;)

 

As for your issue, you have mentioned it worked after you installed the FIRMWARE that I've sent you to previously.

 

If it's working after the firmware installation, try not to update to the newest firmware yet. 

 

At this moment, use the FIRMWARE that I've sent to you and we will escalate your issue to our Product Management for them to test the newest update for the firmware. They might release a newer/updated version for the firmware  and we will inform you when the update is ready.

 

For now, just use the one that I've sent to you  :)

 

Keep us updated!

Share this post


Link to post
Share on other sites
Guest Tt Josh

Hi Josh,

 

Thanks for the UPDATE Firmware, its working my bottom button, i can cange my profiles ( OSD showed UP in my monitor  ). 

Pic :http://imageshack.com/a/img537/4940/Rnplnj.jpg

Pic 2 :  http://imageshack.com/a/img673/4615/rl7w0f.jpg

 

but, still didnt working at all After i update firmware, my mouse stop working, then i read in forum n use "sensor_on_lift_off_tool_v1.0.0.1" 

i still cant use my mouse until i press profil button. and OSD showed : http://imageshack.com/a/img661/7399/o6wMwv.jpgAnd mouse working normally.

 

but after profile "P1" showed UP  i cant cange profil anymore. 

 

  • i tried reinstal AP from CD ( Many time )
  • I tried reinstal AP v1.3
  • i tried reinstal AP v1.3.1
  • i tried restart PC ( many time )
  • i tried reInstal firmware "tt esports theron firmware update tool v1.2" then instal Firmware from drobox u did upload.

Thanks josh n team for helping me :) i will be waiting for next updates

 

Hey General,

 

As you have installed the "TT ESPORTS SENSOR ON LIFT OFF TOOL V 1.0.0.1", open the tool and please ensure that you adjust the "Lift Off" option to the "HIGHEST".

 

And keep using the firmware that I've sent to you for now, and do not update to the newest version for the firmware.

 

Keep us updated if you have any further issue.  ;)

Share this post


Link to post
Share on other sites

Hey General,

 

Sorry for the late reply. We're having our weekend off  ;)

 

As for your issue, you have mentioned it worked after you installed the FIRMWARE that I've sent you to previously.

 

If it's working after the firmware installation, try not to update to the newest firmware yet. 

 

At this moment, use the FIRMWARE that I've sent to you and we will escalate your issue to our Product Management for them to test the newest update for the firmware. They might release a newer/updated version for the firmware  and we will inform you when the update is ready.

 

For now, just use the one that I've sent to you  :)

 

Keep us updated!

 

 

Hey General,

 

As you have installed the "TT ESPORTS SENSOR ON LIFT OFF TOOL V 1.0.0.1", open the tool and please ensure that you adjust the "Lift Off" option to the "HIGHEST".

 

And keep using the firmware that I've sent to you for now, and do not update to the newest version for the firmware.

 

Keep us updated if you have any further issue.  ;)

 

Hi Josh,

 

Yes its worked, but only showed OSD in my monitor, the real profile ( it mean light, DPI, mouse cursor ) not even changed.

 

i did as u asked. but still dsnt work. like i was posted. i should be waiting for new update. :)

 

becoz i cant play game with one profile,i have a lot of games with different type. 

 

thanks for support josh :)

Share this post


Link to post
Share on other sites
Guest Tt Josh

Hi Josh,

 

Yes its worked, but only showed OSD in my monitor, the real profile ( it mean light, DPI, mouse cursor ) not even changed.

 

i did as u asked. but still dsnt work. like i was posted. i should be waiting for new update. :)

 

becoz i cant play game with one profile,i have a lot of games with different type. 

 

thanks for support josh :)

 

Hey General,

 

Glad the mouse is working right now!  :lol:

 

Apologized for the Profile Changing, we might need to wait for a new update for the Profile Change.

 

In the meantime, you'll have to continue with this first and we will prepare the update when it's ready!

 

Hit us whenever you have questions!  ;)

Share this post


Link to post
Share on other sites

Hey General,

 

Glad the mouse is working right now!  :lol:

 

Apologized for the Profile Changing, we might need to wait for a new update for the Profile Change.

 

In the meantime, you'll have to continue with this first and we will prepare the update when it's ready!

 

Hit us whenever you have questions!  ;)

HI josh,

 

did u know when firmware will be update ? :)

Share this post


Link to post
Share on other sites
Guest Tt Josh

HI josh,

 

did u know when firmware will be update ? :)

 

Hey General,

 

Sorry for the late reply! 

 

Can you try to check the bottom of your THERON mouse and make sure you did not lock the mouse...(if is locked, try to unlock it)

 

Keep us updated! ;)

Share this post


Link to post
Share on other sites

Hey General,

 

Sorry for the late reply! 

 

Can you try to check the bottom of your THERON mouse and make sure you did not lock the mouse...(if is locked, try to unlock it)

 

Keep us updated! ;)

Of course not, its unlocked, as i say this is happened after firmware update :(

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...