Jump to content
Sign in to follow this  
Niko.P

PLZ HELP

Recommended Posts

Well, I just bought the Thermaltake Talon Elite RGB Gaming Mouse Combo and it was working fine but the I didn't like the DPI and colour settings. I installed the software for my mouse, it all looked normal but then a pop up said that the app had an update. I click update, it shuts the app, my mouses colour turns off and then nothing. It hasn't worked for the past hour, i've tried the mouse on my sister's laptop and on my xbox and it still doesn't work. When ever I reinstall and open the app it says something like "USB device not found", i've tried all the ports but still nothing.

PLZ HELP

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...