Jump to content
  • Forum Statistics

    3,736
    Total Topics
    30,904
    Total Posts
  • Member Statistics

    100,561
    Total Members
    16,800
    Most Online
    rsaalfrank
    Newest Member
    rsaalfrank
    Joined

jtcowner

Members
  • Content count

    4
  • Joined

  • Last visited

  1. TT esports Poseidon Z RGB software issues

    I reside in the US. Support through phone would be optimal, but email is alright.
  2. TT esports Poseidon Z RGB software issues

    Bump, my problem still persists despite reinstalling the software. The pdf guide seems to hint at being able to delete the default layer, which is the source of my problem. Picture related.
  3. TT esports Poseidon Z RGB software issues

    Hi Josh, so I did exactly what you said, then started my computer today, and the problem persists. I followed your instructions perfectly, yet instead of blue, my keyboard defaults to the red. It's inconvenient to now open the software, go to the color options, and choose the Set and hit apply, because of how slow the software is. Any chance of an update soon?
  4. Hi everyone, first post here. I'm having a bit of trouble with the software that accompanies the TT esports Poseidon Z RGB keyboard. First off, I really do love this keyboard. The clickyness is very satisfying, it's super responsive, and the lights are beautiful. But the software that you must download to change colors, create macros, and do everything else is, to be honest, garbage. It's clunky, slow, and the buttons don't work half the time. Now, in the color effects window, I have a profile set to custom, with a layer on "Set 1." The default is there, because I cannot delete it (despite the help .pdf saying you CAN delete the default set; this is important in a moment). So the problem is, whenever I restart my computer, the keyboard (set to "Profile 1") defaults to a fully-lighted red color, which is not what I want. So when my computer boots up, I have to open up the software, open the lighting menu, and re-apply my custom lighting, which is extremely inconvenient. Any fix to the software? I'm using the latest version (36), and as of typing this and trying to fix it myself, the word "default" and "set 1" are completely missing on "Profile 1." What's the deal here guys? I'm from the US if you need that information.
×