Jump to content

Search the Community

Showing results for tags 'rgb 850w'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Thermaltake
    • Enthusiasts
    • Chassis
    • Power Supplies
    • Cooling
    • Storage
    • Accessories
    • General Discussion
    • Events
    • FAQ
  • Tt eSPORTS
    • Tt eSPORTS PLUS+ Community & Data Management Platform
    • Gaming Mice
    • Gaming Keyboards
    • Gaming Headsets
    • Gaming Controller
    • Gaming Mouse Pads
    • Gaming Accessories
    • Team Tt eSPORTS
    • Tt eSPORTS Streamers
    • Gaming Chair & Gaming Station
    • Tt eSPORTS General Discussion
    • Tt eSPORTS Events
    • Tt eSPORTS FAQ
  • LUXA2 Thermaltake Mobile
    • Power Bank Solution
    • Holder Solution
    • Audio Solution
    • Accessories
    • LUXA2 General Discussion
    • FAQ
  • Others
    • Off Topic
    • Customer Service

Categories

  • Thermaltake
  • Tt eSPORTS
  • LUXA2
  • Others

Blogs

  • Thermaltake
  • LUXA2
  • Tt eSPORTS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. kyuubi85

    RGB 850W

    Im not sure if im posting in the right section. i actually have a RGB 850W psu. recently i change my case and the case have fan with led light installed. After the case change, the psu ring led is not working. The psu is working fine and the fan is working but the light is not working even if i press the buttton. I have 2 monitor installed and R9 370 gpu. when i restart the pc and unplug my second monitor, the psu light is working. Not sure what is the problem with it. Sometime i dont have to unplug the monitor but i need to restart the pc for the psu led ring to be working.
×