Jump to content

Search the Community

Showing results for tags 'riing 14'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Thermaltake
    • Enthusiasts
    • Chassis
    • Power Supplies
    • Cooling
    • Storage
    • Accessories
    • General Discussion
    • Events
    • FAQ
  • Tt eSPORTS
    • Tt eSPORTS PLUS+ Community & Data Management Platform
    • Gaming Mice
    • Gaming Keyboards
    • Gaming Headsets
    • Gaming Controller
    • Gaming Mouse Pads
    • Gaming Accessories
    • Team Tt eSPORTS
    • Tt eSPORTS Streamers
    • Gaming Chair & Gaming Station
    • Tt eSPORTS General Discussion
    • Tt eSPORTS Events
    • Tt eSPORTS FAQ
  • LUXA2 Thermaltake Mobile
    • Power Bank Solution
    • Holder Solution
    • Audio Solution
    • Accessories
    • LUXA2 General Discussion
    • FAQ
  • Others
    • Off Topic
    • Customer Service

Categories

  • Thermaltake
  • Tt eSPORTS
  • LUXA2
  • Others

Calendars

  • Community Calendar

Blogs

  • Thermaltake
  • LUXA2
  • Tt eSPORTS

Found 3 results

  1. Riing 14 rgb Controller issue

    Hey guys, Im using the riing 14 rgb 3x Fan pack in my case and After reboot they dont remember LED settings. Any idea? Thanks, Greetings from germany
  2. I just built a new system today, and I included Riing 14 Premium fans (not the plus), and the software does not connect. I"m getting the message that the controller can't be found. It does load up as "USB Input Device", but when the program opens it can't find the controller. I've tried both USB 2.0 ports on the board, two different molex connectors (with 3 connectors on each) The fans are running, and are red, but I can't change the speed or color I've reinstalled and rebooted more times then I can count and nothing seems to get them to work. I made sure I powered down every time I made a change to software or hardware. Is there anything else I can do? I'm using the latest software off this site (as of today). -Patrick
  3. Fan Controller Problems

    I have recently bought a set of Riing 12s and Riing 14s to put into my NZXT SS340 Case and onto my Cooler Master Hyper 212 Evo. I have a 550W psu and an ASUS M5a97 R2.0 mobo. When i put all the fans in and connect them up to the controllers, with each controller going to a different a PWM slot, one controller works fine, speed lights etc work (red light the controller), but the other doesnt respond to anything (has a blue light on the controller). Is the controller broken or have I connected it to the wrong pin slot????????
×