Jump to content
cadium

Level 10m not recognised by software

Recommended Posts

As per title. My Level 10M mouse is not recognised as plugged into my system byt the configuration software.

When plugged in the mouse works as a regular two button mouse. When moved to a different USB point windows configures the driver for the mouse and correctly identifies it as a Level 10M.

 

Windows 10 home 64 bit

Lastest Thermaltake software installed from the level 10m mouse page.

 

 

suggestion on fixes?

 

 

Share this post


Link to post
Share on other sites
Guest Tt Josh

As per title. My Level 10M mouse is not recognised as plugged into my system byt the configuration software.

When plugged in the mouse works as a regular two button mouse. When moved to a different USB point windows configures the driver for the mouse and correctly identifies it as a Level 10M.

 

Windows 10 home 64 bit

Lastest Thermaltake software installed from the level 10m mouse page.

 

 

suggestion on fixes?

Can you take a screenshot of it? and did you test with another computer or USB port?

Share this post


Link to post
Share on other sites
Guest Tt Josh

Changing USB ports makes no difference. Removing other USB devices makes no difference. I am unable to check on another PC.

attachicon.gifAP Config.png

Did you try to restart your computer?

Share this post


Link to post
Share on other sites
Guest Tt Josh

If only I could. The firmware update doesn't see the mouse either.

attachicon.gifupdate.png

Hi, can you please install the file below and take a screenshot of what being showed? We will need to know more information on this.

 

Click HERE to download

Share this post


Link to post
Share on other sites
Guest Tt Josh

There should be some numbers showing like this:

 

0022c418eae0eb2cceb9153ebc2597c5.png

We'll look into this and will get back to you once we have the solution.

Share this post


Link to post
Share on other sites
Guest Tt Josh

Can you supply me the mouse driver and I can assign it to the usb manually?

We do not have the driver now and the product management team is currently communicating with the vendor and find out a solution to fix this issue. Sorry for the inconvenience.

Share this post


Link to post
Share on other sites

Hi, is there any update to the issue I'm having with my mouse not being recognised by the configuration software (or any of the thermaltake software) please?

At the moment I have an expensive paperweight....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×