Jump to content
Sign in to follow this  
JayTee

Challenger (Gaming) Keyboard not working? Started to write X's?

Recommended Posts

  • Keyboard doesn't work

FN + f1 did nothing

Fn + f2 made it write X's in anything I opened (like a tab)

It tried to delete everything in my C drive when I clicked on something.

Re-installed drivers, still doesn't work

Share this post


Link to post
Share on other sites

 Could you please contact our customer service and we will have someone help you:


 


USA / Canada :


ttsupport@thermaltakeusa.com


Tel: Toll-Free 01-800-988-1088


M-F 9:00AM â€“ 5:30PM (P.S.T)   


 


Mexico :


Por Email: apoyotecnico@thermaltakeusa.com


Por Telefono: 01-800-823-2606


En el D.F: (55)5648-6715 Atencion de 10:00AM a 6:00PM (P.S.T)   


 


Brazil: suporte@thermaltakebr.com


 


Asia: cs2@thermaltake.com.tw


 


Europe:  support@thermaltake.de


Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×