Sign in to follow this  
Followers 0
AvohHD

TT challenger unresponsive keys

2 posts in this topic

 

I  need  your help because suddenly my challenger prime keys won't register just happened today , I have been using the keyboard for almost 7 months now, the enter key is working but i can't type or do anything.Yes i have already tried in different usb ports and also another diff computer.Its still the same, the keys that are unresponsive are these ones : QWER, ASDF, ZXCV, CTRL, ESC, SHIFT. Others are working atm.
 
please help

:(

Share this post


Link to post
Share on other sites

Could you please contact our customer service and we will have someone help you with the RMA:


 


USA / Canada :


ttsupport@thermaltakeusa.com


Tel: Toll-Free 01-800-988-1088


M-F 9:00AM â€“ 5:30PM (P.S.T)   


 


Mexico :


Por Email: apoyotecnico@thermaltakeusa.com


Por Telefono: 01-800-823-2606


En el D.F: (55)5648-6715 Atencion de 10:00AM a 6:00PM (P.S.T)   


 


Brazil: suporte@thermaltakebr.com


 


Asia: cs2@thermaltake.com.tw


 


Europe:  support@thermaltake.de


Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0