Jump to content
Sign in to follow this  

Tt esports Black V2 Mouse (Device Descriptor Request Failed) NOT WORKING.

Recommended Posts

Hey there, I have contacted you guys in all ways possible as this is rather annoying that I am currently mouseless...

I went out yesterday and bought a Challenger keyboard, Black v2 mouse, and RGB hard edition mousepad, however upon opening the mousepad, it didn't work, in attempt to fix it somehow the mouse now does not work, I had to replace the mouse pad because it turned out to be faulty, and I replaced the mouse, still no go, so this is a device driver issue, HOWEVER, for some unknown reason you guys DO NOT list a single driver on your website, and I cannot manually install the driver, so now I have a paper weight mouse that refuses to work.

What can I do, I've literally done everything required for a Code 43 in attempt to fix this problem, no dice, and needless to say I'm quite annoyed as I loyally bought all my accessories from the same brand.

Share this post

Link to post
Share on other sites

Hey David, while I appreciate the reply, neither of those are drivers and simply software, the problem with my Black V2 is that it is throwing a code 43 which means the mouse is failing to install driver upon being plugged in therefore I must manually install the drivers that the mouse would normally install, unfortunately none of these are listed on your website, so instead I continue to receive "Unknown USB Device (Device Descriptor Request Failed)" in my Device Manager, following all requirements on the internet to clear this has not worked which leaves the last option of manually installing the drivers.

Keep in mind this is a brand new mouse, which is the exact same as my old one, and neither of them are working because of Driver failure(or corrupt drivers), the keyboard and mouse pad work, as I had to swap my mouse pad due to the mouse pad being faulty, but I'm stuck with a mouse that is failing to work properly.

I have tried to put this on multiple computers and it does not work, so I'm believing it's possible firmware corruption, unfortunately it's also not listed anywhere.

I believe a possible corrupted driver is causing corrupted firmware because I had an old Black V2 that was doing this so I purchased a NEW Black V2 and it started doing this as well.


Share this post

Link to post
Share on other sites

I think that may caused by the hardware problem. Could you please contact our customer service and replace a new one?http://my.ttesports.com/csWarranty.aspx 

USA / Canada :
Tel: Toll-Free 01-800-988-1088
M-F 9:00AM – 5:30PM (P.S.T)   

Asia: cs2@thermaltake.com

Europe:  support@thermaltake.de

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this