Jump to content
  • Forum Statistics

    6.8k
    Total Topics
    46.6k
    Total Posts
  • Member Statistics

    91,918
    Total Members
    16,800
    Most Online
    skhairuk
    Newest Member
    skhairuk
    Joined

Sir_Musket

Members
  • Posts

    2
  • Joined

  • Last visited

Posts posted by Sir_Musket

  1.  

    Could you please contact our customer service and we will have someone arrange the new version for you:

     

    USA / Canada :

    ttsupport@thermaltakeusa.com

    Tel: Toll-Free 01-800-988-1088

    M-F 9:00AM â€“ 5:30PM (P.S.T)   

     

    Mexico :

    Por Email: apoyotecnico@thermaltakeusa.com

    Por Telefono: 01-800-823-2606

    En el D.F: (55)5648-6715 Atencion de 10:00AM a 6:00PM (P.S.T)   

     

    Brazil: suporte@thermaltakebr.com

     

    Asia: cs2@thermaltake.com

     

    Europe:  support@thermaltake.de

     

    Australia...?

  2. What a way to make my first post here :)

    Hi all, so just 2 days ago I bought the TTE sports shock 3d 7.1 headset. After I got home and opened it I plugged it in via USB and received sound for the first 5 minutes. Then suddenly the sound began coming out from the speakers, I googled the problem and realized I needed to visit this website and install the drivers. I am running on a Windows 10 laptop, so I installed the latest drivers. After half way through the installation a box appeared, "Cannot find any device", then 1 minute later the installation stops and says "Restart computer to allow drivers to fully install" despite restarting my laptop numerous times the issue kept happening. Does anyone know how to fix the problem? is it the model of the headset or the software, I live in Australia for everyone information :)

×
×
  • Create New...