Jump to content

Search the Community

Showing results for tags 'help me!'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Thermaltake
    • Enthusiasts
    • Chassis
    • Power Supplies
    • Cooling
    • Storage
    • Accessories
    • General Discussion
    • Events
    • FAQ
    • Memory
  • Thermaltake Gaming
    • Gaming Mice
    • Gaming Keyboards
    • Gaming Headsets
    • Gaming Mouse Pads
    • Gaming Accessories
    • Team Thermaltake
    • Thermaltake Streamers
    • Gaming Chair
    • Gaming Desk
    • Thermaltake Gaming FAQ
  • Others
    • Off Topic
    • Customer Service

Blogs

  • Thermaltake
  • Tt eSPORTS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 4 results

  1. I recently bought a pc then built it. It was working fine untill I plugged the gdv cable into my fan hub. Because i didnt know what it did. Then smoke appear. I yanked it out. My fans rgb were working untill I turned my pc off and on again. Now the rgb doesnt work. How can I fix?
  2. Hello, I am from Argentina and I am using the translator so sorry if something is not well understood. I have the poseidon z forged keyboard, everything was working fine until I switched to windows 10 and it stopped working. Windows recognizes the keyboard as a sound device, I looked in many places and I could not find the solution, if someone could help me it would be great. So far I tried reseating the drivers, using a different cable, and plugging it into different USBs. I leave you a photo of how the device appears.
  3. Hello, I am from Argentina and I am using the translator so sorry if something is not well understood. I have the poseidon z forged keyboard, everything was working fine until I switched to windows 10 and it stopped working. Windows recognizes the keyboard as a sound device, I looked in many places and I could not find the solution, if someone could help me it would be great. So far I tried reseating the drivers, using a different cable, and plugging it into different USBs. I leave you a photo of how the device appears.
  4. I've had this mouse for a fair while, it's the best mouse I've ever had, and I've always had the side buttons set to volume up/down and one of the middle buttons as pause/play. Recently these bindings stopped working for seemingly no reason. I haven't made any significant hardware changes and I regularly update windows. I have also updated Tt eSPORTS Command Center and completely reinstalled it since the problem began, with no effect. I've checked and the buttons work for other things, such as macros and other mouse functions. Has anyone experienced something similar or have any suggestions on how to fix it?
×
×
  • Create New...