Jump to content

Search the Community

Showing results for tags 'Black V2'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Thermaltake
    • Enthusiasts
    • Chassis
    • Power Supplies
    • Cooling
    • Storage
    • Accessories
    • General Discussion
    • Events
    • FAQ
  • Tt eSPORTS
    • Tt eSPORTS PLUS+ Community & Data Management Platform
    • Gaming Mice
    • Gaming Keyboards
    • Gaming Headsets
    • Gaming Controller
    • Gaming Mouse Pads
    • Gaming Accessories
    • Team Tt eSPORTS
    • Tt eSPORTS Streamers
    • Gaming Chair & Gaming Station
    • Tt eSPORTS General Discussion
    • Tt eSPORTS Events
    • Tt eSPORTS FAQ
  • Others
    • Off Topic
    • Customer Service

Categories

  • Thermaltake
  • Tt eSPORTS
  • LUXA2
  • Others

Blogs

  • Thermaltake
  • LUXA2
  • Tt eSPORTS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 2 results

  1. I used to have a Black Gaming Mouse and Now I recently upgraded to the Black V2 and I came home to install the software for the mouse and it give me an error every time I try to install the software.
  2. Hi Guys, I recently purchased the Black V2 gaming mouse. After initial software issues, I got everything running fine. However, i turned on my computer today and the mouse is suddenly unresponsive. The mouse does not move the cursor anymore, it only clicks. The only light on the mouse is the first DPI level light. I had the same issue with my original Black DTA mouse. I assumed the mouse just died (few years old), however the same issue has come back. Steps I have taken to solve the issue: Rebooting the computer several times. Changed the USB port. Checked the drivers. Uninstalled USB port drivers, replugged in device and the drivers reinstalled. What can I do to solve this issue. I just bought the mouse less than a week ago.
×
×
  • Create New...