Jump to content

Search the Community

Showing results for tags 'x399'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Thermaltake
    • Enthusiasts
    • Chassis
    • Power Supplies
    • Cooling
    • Storage
    • Accessories
    • General Discussion
    • Events
    • FAQ
  • Tt eSPORTS
    • Tt eSPORTS PLUS+ Community & Data Management Platform
    • Gaming Mice
    • Gaming Keyboards
    • Gaming Headsets
    • Gaming Controller
    • Gaming Mouse Pads
    • Gaming Accessories
    • Team Tt eSPORTS
    • Tt eSPORTS Streamers
    • Gaming Chair & Gaming Station
    • Tt eSPORTS General Discussion
    • Tt eSPORTS Events
    • Tt eSPORTS FAQ
  • Others
    • Off Topic
    • Customer Service

Categories

  • Thermaltake
  • Tt eSPORTS
  • LUXA2
  • Others

Blogs

  • Thermaltake
  • LUXA2
  • Tt eSPORTS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Hey guys, I recently put together my Ryzen Threadripper build and i'm using the Gigabyte X399 Gaming 7 motherboard has stated in the title however, I can't get the software to launch on this platform. It's installed properly but when I go to launch it nothing happens. I've tried to run it without the fan hubs connected but it still won't work. Any ideas would be greatly appreciated or maybe its something that TT need to fix in the software....
×
×
  • Create New...