Jump to content

LEVEL 10 M Diamond Black Can't use config


Recommended Posts

Guest Tt Josh

I plugged the mouse into my computer and put the disk in and downloaded the software. I ran it and it won't let me open the config. I re-downloaded from the website and it's still not working.

Hey DrZoddiak,


Did you try downloading this? Try uninstall the previous software and download the UI below:




Try this and keep us updated. ;)

Link to comment
Share on other sites

  • 5 weeks later...
  • 8 months later...
  • 1 year later...

Is there any update to this problem with the mouse not being recognised and the software not running? I haven't seen anything but "we are escalating the issue" over and over again in multiple posts, but not one update since, and these posts go back to july of 2016...


$70+ piece of hardware that it's own software doesn't recognise, Including the "firmware update"... this is rediculous.


Problem exsist for me on win 10 pro x64 platform, on every rig I try it on (total of 6 I own) and it is the same on every one.


Mouse is only recognised by windows as an "HID-Compliant device", no control over the different buttons/keys, lighting, sensitivity, etc without the software and the software won't find it; keeps asking me to "plug in device" and I have done so over and over again in multiple USB ports with no change.. I'm stuck with a $70+ basic mouse. Please do something about a proper driver for this or lets talk about a refund of my purchase. I could have spent $10 bucks for a basic mouse if that's what I wanted... :angry:


(NOTE) mouse and software work fine on win 7 pro x64 platform, so obviously its a win 10 driver issue ( which there appears to be no driver available?), please do something about this already, it's been long enough...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...