Jump to content

Talon gaming mouse DPI setting not functioning properly


iKhriz
 Share

Recommended Posts

I've had my Model No. MO-TLN-WDOOBK-01 Talon Gaming Mouse for a few months now and I've just started experiencing this issue where I can only alternate between the lowest 2 DPI settings, yellow and red. I was wondering if I had simply triggered a setting somehow with the mouse or if it's an issue that indicates hardware degradation but either way I would really appreciate it if someone could give me some assistance regarding this problem.

Thank you.

Link to comment
Share on other sites

Guest Tt Josh

I've had my Model No. MO-TLN-WDOOBK-01 Talon Gaming Mouse for a few months now and I've just started experiencing this issue where I can only alternate between the lowest 2 DPI settings, yellow and red. I was wondering if I had simply triggered a setting somehow with the mouse or if it's an issue that indicates hardware degradation but either way I would really appreciate it if someone could give me some assistance regarding this problem.

 

Thank you.

Hi iKhriz, did you try with another USB port? try it...it should be blue, dark blue and purple.

 

Also please inform us the country you're from. :)

Link to comment
Share on other sites

Hi iKhriz, did you try with another USB port? try it...it should be blue, dark blue and purple.

 

Also please inform us the country you're from. :)

I just tried in all my available USB slots, both 1.0 and 2.0, and none of them fixed the issue.

As for where I'm from, I live in Australia.

Link to comment
Share on other sites

Guest Tt Josh

I just tried in all my available USB slots, both 1.0 and 2.0, and none of them fixed the issue.

As for where I'm from, I live in Australia.

Please contact our local customer support at rma@thermaltake.com.au and we will have person in charge to assist you further.

Link to comment
Share on other sites

  • 3 weeks later...
Guest Tt Josh

Nothing happend, it still only toggles between the 2 lowest dpi modes

Please contact our customer support at ttsupport@thermaltakeusa.com and we will have person in charge to assist you further for the issue.

Link to comment
Share on other sites

  • 3 weeks later...

 I m still waiting for an awnser... I think that im going to stay with a mouse that doesnt work properly

Hi Mallrior, please send the same email to them again and keep me updated on the reply. :)

Link to comment
Share on other sites

  • 1 year later...

Hi, i´ve just bought a brand new TALON BLU, and all functions seems to work properly, all but not the most important one, the DPI´s.


The mouse moves sooooo slow, i click at DPI changer button, it flashes 1, 2 3 even 4 times, but nothing happen. 


The mouse moves so slow.


Try it on every different USB ports on my PC, try it on another PC and even a laptop, but always the same issue.  :(


 


 


My last mouse was another older TALON BLU and it worked great until the middle button breaks, so i was so happy with the performance, that i decide to renew it with the same model, but sadly this is happen. I hope you can help me ASAP.


Thank you guys,

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...