Jump to content

TT Floe DX 240 Dual Riing Duo (Premium Edition) Fans Not Spinning (Working)


Bjonas97
 Share

Recommended Posts

I finished building my new PC, it's not 100% setup yet, meaning I don't have windows installed just yet. The hardware i have are as followed:

MB - Asus Prime Z390-A

CPU - Intel Core i7 9700k 9th Gen

CPU Cooler - Thermaltake Floe DX 240 Dual Riing Duo

RAM - (x2) 16gb TridentZ RGB DDR4

SSD - WD Blue 3D NAND 1TB

GPU - Asus GeForce RTX 2070 Super

PS - Thermaltake Toughpower Grand RGB 850W 80+

Case - Thermaltake View 31 (RGB limited edition) with 3 pre-installed RGB fans with controller.

My issue so far is as soon as I turn on the computer, everything turns on except the fans on the liquid CPU cooler. I plugged the wire coming directly from the pump into the header labeled "AIO Pump" and nothing is plugged into the "CPU OPT" or "CPU FAN" headers, and when I boot up the PC, it gives a "No CPU fan detected" error, but the pump is running. So i removed the pump plug and moved it to the "CPU OPT" header, same error shows. Then I plug it into the "CPU FAN" header, and the error goes away, and I can still feel the pump running. But the Fans are still not spinning. So I plugged the wires directly from the fans into different ports on the controller and still all the RGB lighting turns on but the fans do not spin. I tried looking up videos and forums online, but i could not find anyone with the same issue as mine. Correct me if im wrong, but I'm pretty sure the fans are supposed to turn on as soon as you turn the computer on regardless if I dont have windows and the Thermaltake software installed yet. 

 

Anyone have any more troubleshooting ideas i could try? Or does it sound like the fans or the controller are defective?

 

Link to comment
Share on other sites

You are correct the fans should spin regardless of the software just might not be able to react correctly under load. Can you post some pics of how you have it hooked up. As for the no cpu fan detected that would be bios setting that need tweaking as you should be able to use that aio header without the error.

Link to comment
Share on other sites

See the image attached, this is how I have the controller setup right now. The orange wire is connected to a USB port on the I/o on the back, I've tried each USB port but the fans are still not spinning. I even went into the BIOS to see if I can control the fans, but it only sees the pump which it is identifing it as a fan because it's plugged into the cpu_fan header. I'm completely at a loss, I think the fans are bad.

20200512_152339.jpg

Link to comment
Share on other sites

Ok I found the issue, and I blame this on Thermaltake and their poor choice to continue to use the Molex connector for power to the controller. In a last ditched effort to troubleshoot the issue, I found that one of the prongs in the Molex connector was slightly pushed out. So I pushed it back in and the fans started right up. Hours of frustration Al because of a loose pin in the Molex connector...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...