Jump to content

Trouble with Thermaltake TPG-650M


Seb86
 Share

Recommended Posts

Hello, I writting here because I have some trouble with my Thermaltake TPG-650M and I have no answer when I send a mail.

When I play a game (like GTA V, Shadow of the mordor, heroes & general and 75% of games in my computer), the fan of alimentation starts spinning very fast, as if he was overheated. This brings the net stop the alimentation, so the pc.

I have the required configuration for this game, and no other fan (cpu, gpu or pc) spinning fast, only the fan of your product.

The fan also has some hiccup-like in normal utilisation of the pc (out of game).

If you want my configuration, I have :

- CPU : Intel Core i5 4690K 3.50 GHz 4 cores

- Motherboard : ASUSTeK COMPUTER INC. H97-PLUS Rev X. 0x

- GPU : Nvidia Geforce GTX 970

- RAM : 16 go

- OS : Windows 10 (but same problem with 8.1) 64 bits

 

I want to know if the product is faulty from the factory or if problems come from elsewhere ?

 

Thanks for your understand.

 

ps : I'm french, I explain the problem as the best I can in english.

Link to comment
Share on other sites

Hello, I writting here because I have some trouble with my Thermaltake TPG-650M and I have no answer when I send a mail.

When I play a game (like GTA V, Shadow of the mordor, heroes & general and 75% of games in my computer), the fan of alimentation starts spinning very fast, as if he was overheated. This brings the net stop the alimentation, so the pc.

I have the required configuration for this game, and no other fan (cpu, gpu or pc) spinning fast, only the fan of your product.

The fan also has some hiccup-like in normal utilisation of the pc (out of game).

If you want my configuration, I have :

- CPU : Intel Core i5 4690K 3.50 GHz 4 cores

- Motherboard : ASUSTeK COMPUTER INC. H97-PLUS Rev X. 0x

- GPU : Nvidia Geforce GTX 970

- RAM : 16 go

- OS : Windows 10 (but same problem with 8.1) 64 bits

 

I want to know if the product is faulty from the factory or if problems come from elsewhere ?

 

Thanks for your understand.

 

ps : I'm french, I explain the problem as the best I can in english.

Seems like you are not alone with this issue:

(That's not mine PSU, just found this video on the net..)

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...