Jump to content
Sign in to follow this  
Kingprizrakus

Challenger Ultimate - 4 buttons do not work

Recommended Posts

Hi guys ! I have a problem, 4 buttons of my Challenger Ultimate keyboard are not working:

F12, PrtScn, ScrLK, Pause :/

These buttons are located close to each other and have never experienced any liquid / chemical / physical harmful influence.

 

What I have tried:

    1. Removed the buttons and tried carefully pressing their membranes

    2. Manually disassembled a keyboard and checked that two films with electrical lines and contacts - are correctly located

    3. Reset all the keyboard internal profiles

Unfortunately, these steps were not enough to fix these buttons (meanwhile, all the other buttons are working)

 

Please tell, what other things I could try - to fix these 4 buttons?

(replacing a keyboard is not possible in my case)

post-99864-0-29906800-1454609167_thumb.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...