Jump to content

Poseidon Z RGB broken?


Recommended Posts

After installing the ttesports windows software for the Poseidon Z RGB, the lights on my keyboard suddenly turned off. The computer recognizes the keyboard but the keyboard does not work. Toggles keys do not work either, the keyboard does not even light up now. I have tried reinstalling the drivers and none of that worked. I tried the keyboard on three different computers and it does not even light up, let alone work. It was working just fine until I installed the software. Help please ;-;

Link to comment
Share on other sites

I have the same issue running under Windows 7.  I uninstalled the new software 1.40 which tried to install firmware 48.  I then installed version 1.312 and ran C:\Program Files (x86)\Tt eSPORTS\POSEIDON Z RGB\FwChack.  This installed firmware 40 again.  After rebooting a couple of times, forcing 40 onto the keyboard by running the app till it showed that 40 was installed and having an extra keyboard handy I was able to get firmware 40 up and running again. I now have it working and I'm currently using it again but this firmware process has given me a very bad experience.  I originally installed it with the thought that it might help the issue where the keyboard enters keys that I'm not pressing but I think that issue is really a hardware issue.  Like the feel and the keyboard but these issues are causing me problems.


Link to comment
Share on other sites

Please update the firmware, the steps are as follows:  

1.  Download TT ESPORTS POSEIDON Z RGB-SOFTWARE from our website.

2.  Open the software and install it.

3.  Open the file FWUpdate.exe in the folder

C:\Program Files\TteSPORTS\POSEIDON Z RGB\FwChack\FWUpdate


(Current firmware version: 0 is error.)

Click the Start Update

4.  Wait for the update finish, click Finish.


Confirm the current firmware is the newest version.  

If it doesn’t, run the update again.

5.  Restart the computer and finish the update.


Link to comment
Share on other sites

Note I ran the update for the firmware multiple times using Windows 7 by running the FWUpdate application.  Every time I restarted FWUpdate I would see 0 as the firmware version.  I was able to get the previous version of the application to install 40 using the same methodology.  I've tried this procedure twice with multiple reboots to try to get the operating system to see the keyboard.  Each time I couldn't get the keyboard working till I manged to flash 40 onto the keyboard by using another keyboard to be able to login after a reboot.  Note when I wasn't able to get the keyboard to work I did send an email to your support group but never got a reply.  Thankfully installing the older version of the software and firmware got the keyboard working so that I can use it to type this statement. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...