Jump to content

Ryzen Threadripper X399 Gigabyte Motherboard Riing Plus Software Problems


Deadarmour
 Share

Recommended Posts

Hey guys,

I recently put together my Ryzen Threadripper build and i'm using the Gigabyte X399 Gaming 7 motherboard has stated in the title however,  I can't get the software to launch on this platform.  It's installed properly but when I go to launch it nothing happens.  I've tried to run it without the fan hubs connected but it still won't work.  Any ideas would be greatly appreciated or maybe its something that TT need to fix in the software.... 

Link to comment
Share on other sites

Good news! I've found a usb port on that back of the motherboard that will allow the software to open with the controllers to be plugged in however, the controllers are still a little wonky with fan control.  Is there any news of new controllers being sent out!? or when you'll actually be able to plug these things into a pined 2.0 motherboard port?

Link to comment
Share on other sites

  • 3 weeks later...

Haven't tried any of the fixes, but I did contact TT USA and got a reply today. Just RMA the controller and they will send over a AM4 replacement. The catch is that you can't use your fans until then. Which is dumb because I bought a 5-pack and I'm not sure whether to hold off for the software fix or send in the controller. I'm seriously debating on returning the fans as well,

Link to comment
Share on other sites

  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...