Jump to content
Sign in to follow this  
vodkavodkabears

TT Sync Controller Issue

Recommended Posts

TT Sync Controller CL-O015-PL00BL-A

 

First off, huge fan of the community!

I've been lurking mostly when I run into issues but now I decided to join as I am having an issue I can't figure out.

I currently have six Thermaltake Riing Plus 140mm Premium fans connected to my system.

 

I was having too many issues with the Gen 3 controllers and daisy chaining so I decided on a TT Sync Controller.

I've either missed something or I can't find the answer I'm looking for. I've tried Thermaltake's Youtube Channel, Support documents, guides, etc.

https://thermaltakeusa.zendesk.com/hc/en-us/articles/360002918633-Thermaltake-RGB-Guide

This was a huge help in identifying a few things and what generation controllers I had before.

 

Before I go into my issue, I'll post my hardware:

ASUS ROG STRIX X370-I GAMING AM4 Motherboard

Ryzen 5 2600x

650w EVGA Gold rated Power Supply

 

I've got the TT Sync Controller plugged in with six fans, and a PWM connector for both sets of three. Given that my board only has three fan headers, and the AIO pump is being used by my Kraken x62, I first tried CPU and CHA_FAN. Each header controlling three fans on the TT Sync Controller.

 

All fans light up perfectly! However, two of them would spin with an eventual third joining in on the race.

 

The other three fans will either act like they're trying to move, or not at all.

 

Here's all the troubleshooting I've done so far:

1. Set fans to DC instead of PWM and put them at 100% - Same three fans spin at 100%, no change.

2. Set fans to PWM on 100% - Same three fans spin at 100%, no change.

3. Plug the infamous PWM Silverstone SATA powered fan hub into the CHA_FAN header, and then plug in the Thermaltake PWM connectors there, repeat 1 - 2 in troubleshooting. Same Results

4. Flipped that silent mode switch on my PSU to see if that was causing issues, no change. 

5. Tried the Generation 3 controllers again. Only two would spin, none of the other fans or the second controller would come up <-- This is the reason I invested in the TT Sync Controller, I spent about 10 hours on this issue alone. I tried all the tips, tricks, Ryzen tricks, etc. 

6. Tried Speedfan, and other fan programs. Doesn't see the fans.

 

Any insight or help on this would be amazing. I know there are other topics on this but I couldn't find anyone having an identical issue. I made sure to check for a solid hour before posting, but if I missed something don't be afraid to post it and call me out! I'd just love to get all six of my fans working.

 

Thanks!

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...