Jump to content

Search the Community

Showing results for tags 'Not working'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Thermaltake
    • Enthusiasts
    • Chassis
    • Power Supplies
    • Cooling
    • Storage
    • Accessories
    • General Discussion
    • Events
    • FAQ
  • Tt eSPORTS
    • Tt eSPORTS PLUS+ Community & Data Management Platform
    • Gaming Mice
    • Gaming Keyboards
    • Gaming Headsets
    • Gaming Controller
    • Gaming Mouse Pads
    • Gaming Accessories
    • Team Tt eSPORTS
    • Tt eSPORTS Streamers
    • Gaming Chair & Gaming Station
    • Tt eSPORTS General Discussion
    • Tt eSPORTS Events
    • Tt eSPORTS FAQ
  • LUXA2 Thermaltake Mobile
    • Power Bank Solution
    • Holder Solution
    • Audio Solution
    • Accessories
    • LUXA2 General Discussion
    • FAQ
  • Others
    • Off Topic
    • Customer Service

Categories

  • Thermaltake
  • Tt eSPORTS
  • LUXA2
  • Others

Calendars

  • Community Calendar

Blogs

  • Thermaltake
  • LUXA2
  • Tt eSPORTS

Found 7 results

  1. After finally installing a new firmware update for my 3 year old Theron, after the update, all buttons except the profile, Mouse Button 1 and 2 and the scroll wheel stopped working. The DPI up and down, all side buttons stopped working. I have tried uninstalling and reinstalling the driver, i have tried in different PC's and USB's slots, restarting the PC doesn't work. There is no response, even in the profile manager and now the driver is called HID-Compliant Mouse and not Ttesports Theron. I'm not sure what to do and I do not want to buy a new mouse as other than that it works fine. If you would like any additional information, ask in the comments. Thanks Liquidity
  2. Hello. I have had my new pc for about 3 weeks with no troubles. last week the mouse started cutting out. are there drivers i can install for this mouse? something? thankyou for any help you can provide:)
  3. i did every thing to set macro but its not working i changed to game mod and its not working either ,, how to set macro keys in game ? i wanna that T1 will buff me with all my buffs ,, i did record pressed 12345678 and then pot record and named macro select by name T1... and it still not working W The F >>>??? how to set macro keys #### dammit ,,, and enother question .. how can i set that colors will be changed outomaticly ,????
  4. Poseidon Z RGB not turning on

    Hi, I just got my Poseidon Z RGB in the mail and have been customizing it for about an hour when it suddenly shut off and isn't turning on, lights and all! Please Help.
  5. i purchased my mouse in 2 february 2015 but now it starts disconnecting everytime i move the mouse so please help me how to claim warranty. i attached my bill theronmouseinvoice.pdf
  6. V71 Fans not working

    Hey everyone, I recently brought a V71 Case and the three 200mm fans aren't working and also the Fan Speed & LED buttons on top of the case don't work. Everything seems to be connected properly so I am not to sure it may be faulty? Any suggestions? Thanks. Karsten
  7. Hi guys wondering if you can help me out here. I installed a couple RGB Riing fans in my case, but they are behaving strangely. I'll try to explain the main things the best I can with bullet points: When I turn my PC on, the fans will spin. One fan is plugged into the controller where the white dot is. When I first turn my PC on, both fans will light up for a second, but: The lights will turn off again (fans keep spinning though), or: One fan will stay lit, while the other still spins, but has no lighting. "low RPM mode" (or whatever the official name for that is), just turns the fans completely off, they don't seem to go to a lower RPM at all. I could be mistaking it though, but the blue light on the controller is 'normal' mode, and when you push the speed button the light should turn red and the fans should slow to a lower RPM? Happy to provide any other information as needed! Thanks.
×