Sign in to follow this  
Followers 0
Tt David

VENTUS X Optical RGB Owner's club

39 posts in this topic

10 hours ago, Tt David said:

Which is M1, M2, and M3?

I really have no clue what you mean. Do you mean the settings, per button? In that case, see the screenshots below. I left those settings alone so they are set as they are by default, after installing.

Edit: oh I think I know what you mean now :)
M1 = Left mouse button
Tt-vx-M1.PNG

M2 = Right mouse button
Tt-vx-M2.PNG

M3 = Scrollwheel button
Tt-vx-M3.PNG

Share this post


Link to post
Share on other sites

Thanks for update. We will pass these information to our PM team and let you know if there is any update :D

Share this post


Link to post
Share on other sites

Sorry for the delay. We already asked our PM team to fix this issue with the firmware. I will ask the schedule for you.

Share this post


Link to post
Share on other sites

Hello,

Two times i've used the  eRMA Service, heard nothing back. Also send an email to support@thermaltake.de, but again to no awail.

Regards,

Erfie

Share this post


Link to post
Share on other sites
On 2017-6-17 at 0:58 AM, Erfie said:

Hello,

Two times i've used the  eRMA Service, heard nothing back. Also send an email to support@thermaltake.de, but again to no awail.

Regards,

Erfie

Hi Erfie, did you try our new software and update your gaming mouse firmware?

Share this post


Link to post
Share on other sites
On 19/6/2017 at 3:39 AM, Tt David said:

Hi Erfie, did you try our new software and update your gaming mouse firmware?

Yes, it does nothing.

The mouse still has the same problem, it can't save 400DPI

 

The real question is this; Why does nobody reply to the eRMA tickets/emails? That's some really awful customer support...

Share this post


Link to post
Share on other sites
On 6/8/2017 at 0:02 PM, Tt David said:

We already combined the firmware update with our Command Center V2.0. You can download the latest version and then update your Ventus X RGB firmware now.

http://www.ttesports.com/files/Product_download/tt_esports_command_center_v2.0009.rar

I have uninstalled the old driver, installed the new driver and indeed it asked me if I wanted to upgrade. Did that and together with the new software, all 3 of the bugs seem to have been resolved. Thanks!

Share this post


Link to post
Share on other sites
9 hours ago, pindle said:

I have uninstalled the old driver, installed the new driver and indeed it asked me if I wanted to upgrade. Did that and together with the new software, all 3 of the bugs seem to have been resolved. Thanks!

Thanks for update :)

Share this post


Link to post
Share on other sites
8 hours ago, Tt David said:

Thanks for update :)

Np glad it worked so well! 

 

Btw I already mailed this to the official EU email address list (info@thermaltake.eu), but haven't gotten a reaction so far. Just a heads up; these domains listed on the website have been down for some time:
Italy : http://it.thermaltake.eu
Netherlands : http://nl.thermaltake.eu
Spain : http://es.thermaltake.eu

Might be whise to fix it or just unlist them from the main site :P 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0