cableitoh

My Tt Riing RGB fans are not working too

5 posts in this topic

I know here have a lot of discussions on the Tt Riing RGB fans are working. I just have to say it. Mine are not working too. Bought them brand new 3x140mm & 3x120mm the two controllers can not even recognized the fans. Please help me, my system is boiling up. 

Share this post


Link to post
Share on other sites

Hi,

Let us know what fans you exactly have, to give an idea, if it is one of the software models, try to push in the micro USB (on the controller side) into the controller really hard. Have your system up and look/listen for the USB detection notification. If you see it when pushing in, it might just be a bad cable and we can replace it.

Keep us posted or just call our support to get a solution in process today.

Share this post


Link to post
Share on other sites
On 4/20/2017 at 8:38 AM, ThermalMike said:

Hi,

Let us know what fans you exactly have, to give an idea, if it is one of the software models, try to push in the micro USB (on the controller side) into the controller really hard. Have your system up and look/listen for the USB detection notification. If you see it when pushing in, it might just be a bad cable and we can replace it.

Keep us posted or just call our support to get a solution in process today.

Hi, try that and the controller & the software cannot even detect the fans are there. My system is boiling up due to the fans problem and I have contacted support. No replay just yet.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now