Jump to content
  • Forum Statistics

    8,260
    Total Topics
    40,890
    Total Posts
  • Member Statistics

    46,272
    Total Members
    16,800
    Most Online
    ghvbnmkopadq
    Newest Member
    ghvbnmkopadq
    Joined

Keyfurrr

Members
  • Content Count

    2
  • Joined

  • Last visited

  1. Hi Alvin! I have sent you a PM. Thanks for attending this thread.
  2. Hello, I recently purchased the Riing 14 Premium edition fans for my new build but it is not working as per expectations. After installing all the drivers and the software from the website, the software does not detect the 3 fans. Here are the things that i have tried. I've connected the fans into different headers from the controller. I've connected the fan controller into all of the 9 pin USB2 on my motherboard. I've connected different Molex cables into the fan controller. I've used different points of my power supply. I've used both of the USB ports from the controller cables. I've tried all the controller number settings i could from the back of the controller. I've tried using a different machines. I've tried downloading different versions of the software. The older version will have 3 fans displaying at 0 RPMs and i'm not able to control the fans still. And still i cannot get the software to detect the fans. I think i am not the only one with this issue. I need advice on this. Please help. The main star of this build were the fans My build as such. Asus Z170-A Motherboard. Intel i7-6700K Superflower 750W Modular Gold. *I think these are the parts I need to list for the "debugging". **All parts purchased on 23rd December 2016. ***Thermaltake fans ordered online on 12th December 2016. ****Thermaltake fans arrived on 22nd December 2016. *****Location: Singapore
×
×
  • Create New...