Jump to content
  • Forum Statistics

    5,854
    Total Topics
    39,032
    Total Posts
  • Member Statistics

    57,012
    Total Members
    16,800
    Most Online
    khalidou94
    Newest Member
    khalidou94
    Joined

Davide

Members
  • Content Count

    3
  • Joined

  • Last visited

Everything posted by Davide

  1. You are right... The problem is not the kb but the mobo. I will wait a next new Bios update with the hope it can solve this issue. Thanks a lot for your support David.
  2. Hi David, yes the keyboard work on other computer. Another singulatity is that the keyboard not work when I remove the Ac power cord. If shutdown but not remove Ac power it work great. At this point I presume it's a strange incompatibility between kb and my x370 mobo. I have no other ideas...
  3. Hi guys, I have an annoyng problem with my meka g1 an my new ryzen configuration (AsRock x370 fatl1ty k4 + r5 1600). At startup of pc the keyboard is not detected, nothing works and I can't also access to BIOS, I must unplug the usb cable and plug it again to see keyboard's led power on and use it. I try to change usb port (rear and front), update chipset, update BIOS to last version, delete standard driver an reinstall it but nothing change, the strange thing is that the other usb peripherals like printer or mouse works great, only meka have this behavior. Someone have a similar situation or solved this. I hope in your support Thanks. P.S: sorry for my english....
×
×
  • Create New...