Jump to content
  • Forum Statistics

    6,232
    Total Topics
    42,015
    Total Posts
  • Member Statistics

    72,292
    Total Members
    16,800
    Most Online
    williamzermeno2
    Newest Member
    williamzermeno2
    Joined

Tigertron

Members
  • Content Count

    5
  • Joined

  • Last visited

  1. I managed to find out that it is in fact a cord issue and it only works when the cord is bent a certain way but i dont think i have the receipt in order to get a new one or ask for repairs...
  2. When i restarted my computer from the power the microphone led was on then flashed a few times but turned off.
  3. Does anyone know how to fix? i bought my cronos riing 7.1 last year and after i plugged it into a friends computer and back into mine the rgb in the headphones has stopped working the dragon logo is illuminated with the proper rgb but the mic and headphones leds are permenatly off and ive tried reinstalling the software and many other things like turning my computer off from the power and unplugging my headset and nothing has fixed the rgb i can still hear out of it as well the rgb just doesnt work.
  4. Does anyone know how to fix? i bought my cronos riing 7.1 last year and after i plugged it into a friends computer and back into mine the rgb in the headphones has stopped working the dragon logo is illuminated with the proper rgb but the mic and headphones leds are permenatly off and ive tried reinstalling the software and many other things like turning my computer off from the power and unplugging my headset and nothing has fixed the rgb i can still hear out of it as well the rgb just doesnt work.
×
×
  • Create New...