Jump to content
  • Forum Statistics

    8,260
    Total Topics
    40,890
    Total Posts
  • Member Statistics

    46,272
    Total Members
    16,800
    Most Online
    ghvbnmkopadq
    Newest Member
    ghvbnmkopadq
    Joined

Spax123

Members
  • Content Count

    5
  • Joined

  • Last visited

About Spax123

  • Rank
    Beginner

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. So after an update the software is recognising the keyboard and is working now, however I cannot change the colours of the backlight on the keyboard itself and the windows key lock doesnt work unless the software is open. (sorry posted the same thing twice by accident)
  2. So after an update the software is finally working but now i cant change the colours on the keyboard itself on use the windows key lock unless the software is open.
  3. Even after reinstalling Windows and installing the thermal take rgb software the keyboard still doesnt show up.
  4. Hi Jackie thanks for the reply. I have an ASRock Z75 Pro3 motherboard, an Intel Core i5 3470 cpu, 8GB of ram, Nvidia GeForce 1070 ti graphics card and am running the most up to date version of Windows 10. Heres a screen recording of what is happening when i run the software. Thanks. X1_RGB.flv
  5. Can someone please help me because I'm starting to get really frustrated with this. The software just says "Please plug in Thermaltake device to get started". I've tried uninstalling and reinstalling the software several times. I've tried disconnecting and reconnecting the keyboard when the software is running and when it's closed. I've tried removing the keyboard within Windows device manager. I've tried plugging the keyboard into different USB ports both USB 2 and 3. I had several versions of Microsoft Visual C++ redistributable installed from games so I removed all of them and tried reinstalling the software in case they were conflicting with the version that comes with the software installer and still no luck. Sometimes when the software starts the keyboard shows up at the top of the window for about a second and then disappears which is strange. I've tried contacting Thermaltake about this issue TWICE and in over a month and still haven't received a reply. This is my first Thermaltake product and I don't want it to be the last because I absolutely love the keyboard itself but I can't even use half of its features because the software designed for it won't even work. So sorry for the rant but if someone could please give me some advice it would be much appreciated because Thermaltake themselves clearly cant be bothered.
×
×
  • Create New...