Jump to content
  • Forum Statistics

    6.8k
    Total Topics
    45.1k
    Total Posts
  • Member Statistics

    87,982
    Total Members
    16,800
    Most Online
    WilliamJoseph
    Newest Member
    WilliamJoseph
    Joined

Spax123

Members
  • Posts

    5
  • Joined

  • Last visited

Posts posted by Spax123

  1. Can someone please help me because I'm starting to get really frustrated with this.

    The software just says "Please plug in Thermaltake device to get started".

    I've tried uninstalling and reinstalling the software several times.

    I've tried disconnecting and reconnecting the keyboard when the software is running and when it's closed.

    I've tried removing the keyboard within Windows device manager.

    I've tried plugging the keyboard into different USB ports both USB 2 and 3.

    I had several versions of Microsoft Visual C++ redistributable installed from games so I removed all of them and tried reinstalling the software in case they were conflicting with the version that comes with the software installer and still no luck. Sometimes when the software starts the keyboard shows up at the top of the window for about a second and then disappears which is strange.

    I've tried contacting Thermaltake about this issue TWICE and in over a month and still haven't received a reply. This is my first Thermaltake product and I don't want it to be the last because I absolutely love the keyboard itself but I can't even use half of its features because the software designed for it won't even work.

    So sorry for the rant but if someone could please give me some advice it would be much appreciated because Thermaltake themselves clearly cant be bothered.

     

×
×
  • Create New...