Jump to content
  • Forum Statistics

    6,255
    Total Topics
    42,052
    Total Posts
  • Member Statistics

    71,071
    Total Members
    16,800
    Most Online
    cirnixrxpill
    Newest Member
    cirnixrxpill
    Joined

yardglass

Members
  • Content Count

    7
  • Joined

  • Last visited

  1. -Bump- still not fixed as of yet Doesn't register in device manager as a USB HUB or any generic device
  2. Sadly, it didn't work with that version of the software, ill try to reseat the 9pin connection into the motherboard
  3. Cheers, ill give that a go now, ill let you know how it goes
  4. I bought mine brand new and the controller never even registered with the computer, so something is defiantly off about this!
  5. i7-6700 GA-H170-D3H Win10 64bit 16gb DDR4 GTX 980 EVGA Connected via molex power connector from PSU into the control unit, then fans connected in, then USB connected to the motherboard at the bottom in the free USB 9 pin plug - still gets nothing from the 9pin USB, or off on the motherboard from the USBs on the rear IO shield will get a photo soon and edit the post
  6. Howdy, i just bought a brand new set of the ThermalTake Riing 12 3 pack Radiator fan TT Premium edition and it seems i cannot get the software to register my control box, i';ve hooked up via usb via motherboard and to the back of the motherboard with a micro usb to no available it wont register anything. I've reinstalled the program numerous of times. Any help would be appreciated
×
×
  • Create New...