Jump to content
  • Forum Statistics

    7,418
    Total Topics
    40,755
    Total Posts
  • Member Statistics

    47,940
    Total Members
    16,800
    Most Online
    kahuhas
    Newest Member
    kahuhas
    Joined

saviorbruce

Members
  • Content Count

    1
  • Joined

  • Last visited

  1. I previously bought a TT Theron and it works great, so I want to try the new Theron Plus. However, the new mouse seems disappointing. I found at least 3 problems after I plugged in my windows 10 computer and installed the latest software. First, when I set it to 1000Hz, the DPI of this mouse dropped substantially. For example, I set the mouse to 3000 dpi, the actual moving speed on my screen is below 2000dpi. (I measured by myself) With the same setting my Theron Plus is moving noticeably slower than my Theron. But 500Hz or lower seems fine. Second, the light on "normal" setting can not be adjusted. The "apply" button is grey and nothing happened when I tried to change the color. Third and the most annoying problem is that the macro settings are completely not working. I noticed several previous posts complaining about the macro issues. In my case, I tried all the possible ways and the "T key" option is not working at all. (It works fine with my old Theron on the same computer.) Other "single key" functions such as "right click" do work though. I assume it is the driver issue instead of hardware problems. I'm using windows 10 64 bit so I'm not sure if the same issues stay for windows 7 or windows 8 systems. I have tried to reset my mouse and it doesn't help. Please let me know if there is anything I can do, or there is a new version of the driver coming out fixing everything.
×
×
  • Create New...