Jump to content

Search the Community

Showing results for tags 'faulty'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Thermaltake
    • Enthusiasts
    • Chassis
    • Power Supplies
    • Cooling
    • Storage
    • Accessories
    • General Discussion
    • Events
    • FAQ
    • Memory
  • Thermaltake Gaming
    • Gaming Mice
    • Gaming Keyboards
    • Gaming Headsets
    • Gaming Mouse Pads
    • Gaming Accessories
    • Team Thermaltake
    • Thermaltake Streamers
    • Gaming Chair
    • Gaming Desk
    • Thermaltake Gaming FAQ
  • Others
    • Off Topic
    • Customer Service

Blogs

  • Thermaltake
  • Tt eSPORTS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 3 results

  1. I've owned this mouse for over 3 years and suddenly it's stopped working yesterday. The lights will come on when I plug it in and also when I click the buttons but no clicks will register and the cursor will not move. I've tried uninstalling all theron files and the 2 tT eSPORTS THERON devices in device manager and restarting my laptop but to no avail. However, plugging the mouse into my friends computer it works fine. I really need some assistance, I have some important work I need to do at the moment and the mouse pad isn't cutting it. Any help as soon as possible is much appreciated.
  2. So, about 3 weeks ago, my CRONOS White headset had begun flaking out, with the cable that lights up the headset, causing static through the headset itself. I unplugged the USB cable, and went on, without lights. Then about 2 weeks ago, the headset's main audio began faulting. I have to hold the cable at a perfect 45 degree angle for any sound to come through. I decided to contact support. The RMA support page says to expect a response within 24 hours. I submitted this ticket around 10 days ago. I sent a follow up RMA 3 days ago, still nothing. I've had to contact support in the past, for the e
  3. Just thought I might mention a clear quality control issue you guys appear to be having, I recently purchased a TT esports Challenger Pro as my new gaming keyboard and immediately had a problem with it not connecting. I found the mini usb port where the cord connects was very loose which meant the keyboard was unable to maintain a signal. A large amount of force was required to gain a connection and when released the cord would immediately disconnect. Though it was possibly just the cord, either way I took it back to my seller to get a replacement. I then went home with a new Challenger Pro a
×
×
  • Create New...