Jump to content

Search the Community

Showing results for tags 'windows 10'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Thermaltake
    • Enthusiasts
    • Chassis
    • Power Supplies
    • Cooling
    • Storage
    • Accessories
    • General Discussion
    • Events
    • FAQ
    • Memory
  • Thermaltake Gaming
    • Gaming Mice
    • Gaming Keyboards
    • Gaming Headsets
    • Gaming Mouse Pads
    • Gaming Accessories
    • Team Thermaltake
    • Thermaltake Streamers
    • Gaming Chair
    • Gaming Desk
    • Thermaltake Gaming FAQ
  • Others
    • Off Topic
    • Customer Service

Blogs

  • Thermaltake
  • Tt eSPORTS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 5 results

  1. Hello. I have had my new pc for about 3 weeks with no troubles. last week the mouse started cutting out. are there drivers i can install for this mouse? something? thankyou for any help you can provide:)
  2. Hi Community! I've recently bought the ThermalTake Poseidon Z RGB (Cherry Brown) and I had installed the software and set it up perfectly on my Windows 8 Pro machine. I had tested all lighting functions within the Effect Control section of the software (Fully Lighted, Reactive, Arrow Flow, Wave and Ripple) which worked beautifully. Although from what it seems now, after updating to Windows 10, the lighting on the keyboard is either non-existent or seems like it's got a mind of its own. >> Here's a quick summary of issues: - There are no longer any proper full colours displaying (Red,
  3. Hi all, I have the issue with keyboard Challenger Pro. Cannot run software on win 10 (64 -bit). I have tried all compatibility modes + run as administrator, but w/t any success. The GUI even doesn't start. However, I can see the process in Task Manager. Has anyone run into the same problem? How can I fix it? TIA!
  4. I built a system with a Asus Z170 Pro Gaming motherboard. I hooked power up the power cable for the docking station and ran the sata connector to one of my sata ports on my mother board. The hot swap feature of the docking station isn't working. It will read the drive on a system reboot but no hot swap. I tried sticking the sata cable into one of the sata express ports on my motherboard but that didn't work either. The manual says to activate the AHCI function on my mother board but I couldn't find an option for that when I ran Bios, maybe it comes preset? I am running Windows 10 Pro Full
  5. I just bought the CHALLENGER Prime and tried to install the software of it on Windows 10 but it gave me a bunch of errors and it didn't install. The keyboard is working fine though and I configured my keyboard on a laptop running Windows 8.1.
×
×
  • Create New...