Jump to content

Search the Community

Showing results for tags 'rl 360'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Thermaltake
    • Enthusiasts
    • Chassis
    • Power Supplies
    • Cooling
    • Storage
    • Accessories
    • General Discussion
    • Events
    • FAQ
    • Memory
  • Thermaltake Gaming
    • Gaming Mice
    • Gaming Keyboards
    • Gaming Headsets
    • Gaming Mouse Pads
    • Gaming Accessories
    • Team Thermaltake
    • Thermaltake Streamers
    • Gaming Chair
    • Gaming Desk
    • Thermaltake Gaming FAQ
  • Others
    • Off Topic
    • Customer Service

Blogs

  • Thermaltake
  • Tt eSPORTS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Salutations, I have just completed a computer build and I am having a few issues that I assume to be PSU issues. I got a Toughpower DPS G RGB 1250W power supply. I got the TT DPS G PC app, and when I launch it, it says "NO Device Detected." I'm not sure why, but because of that, I cannot monitor my PSU or access the features. Is there any solution to this? Additionally, my computer will often restart out of the blue when doing things that it should have no issue doing, like playing a game or surfing the internet. I assume this to be a PSU issue as well. All of my drivers are up to date, a
×
×
  • Create New...