Jump to content

Search the Community

Showing results for tags 'troubleshooting'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Thermaltake
    • Enthusiasts
    • Chassis
    • Power Supplies
    • Cooling
    • Storage
    • Accessories
    • General Discussion
    • Events
    • FAQ
    • Memory
  • Thermaltake Gaming
    • Gaming Mice
    • Gaming Keyboards
    • Gaming Headsets
    • Gaming Mouse Pads
    • Gaming Accessories
    • Team Thermaltake
    • Thermaltake Streamers
    • Gaming Chair
    • Gaming Desk
    • Thermaltake Gaming FAQ
  • Others
    • Off Topic
    • Customer Service

Blogs

  • Thermaltake
  • Tt eSPORTS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 5 results

  1. One of my Riing Quad fans is displaying incorrect colors on the center ring. Wondering if there is any troubleshooting I can do, or did I just get a bad fan? Any help is appreciated.
  2. I've encountered a problem with my ThermalTake Floe Riing RGB 240 Liquid Cooler. The LEDs for the fans are lit but the fans are not spinning. Also I am unable to adjust the fan speed due to Controller error. I am able to adjust the fans LEDs but only under the Lumi Plus plus setting. Whenever I switch the dropdown menu to the Riing Plus selection I get a popup that says, "Warning Controller 1." I have double checked everything and it is all plugged in correctly with power and the correct dip switch settings. In my screenshot both 2 & 3 are the fans and 2 is experiencing the controller erro
  3. I recently got my Neptune elite rgb blue for Christmas, so I plugged it in, installed the software and I was confronted with a notification that there is a driver upadate available, so I updated. when the update was 40-50% through the lights on the keyboard turned off as expected, but after the instillation the kaeboard was not working, after a restart I realised that the keyboard was detected as a "generic USB input device" and I after 30 mins of looking around on the internet trying different things I haven found a solution.
  4. Hello I've recently purchased a thermaltake challenger prime RGB keyboard and mouse combo and I'm very dissapointed with it. It has a problem with the spacebar key, I use my left thumb to press it when typing and most of the times it seems that the space bar registers two keystrokes at once resulting in two spaces between words in the sentences. You can notice this even in this text I'm typing and it's very annoying. I returned the keyboard to the computer shop where I bought it thinking there was something wrong with it and they gave me a brand new one. However the new keybo
  5. I purchased and installed a "Thermaltake Pacific RL120 Water Cooling Kit" in my computer, and it worked perfectly fine for past 6 months. Just few days ago though, my computer overheated and turned itself off. I realized that there was air in the pipes that may have caused water to not pump properly and therefore the overheating the system. I filled more liquid to get rid of air, and in the process found out that one of the pipe was loose. I drained the water loop and redid the entire loop (this time everything is perfectly fit). Now, when I turn on the power the water won't pump back up
×
×
  • Create New...