Jump to content

Silver River III 5G + 5TB WD Red not working properly

Recommended Posts



Recently I have purchased a 5TB WD Red HDD and a Silver River III 5G enclosure for it. Unfortunately they seem not to work properly with each other.

I tried several usecases:

  1. Attach the enclosure with drive to a win 7 x64 system - win 7 wasn't able to discover the drive from computer management app (Win+R->control admintools->computer management)
  2. Reboot to a Ubuntu 14.04 x64 system - situation is better, gparted sees the disk and i was able to make two(4TB + 1TB) ntfs partitions on it.
  3. Again reboot to win 7 x64 (the drive was partitioned from gparted under ubuntu) - still no luck, the system can't see the drive.
  4. Connect the enclosure with the drive to ASUS RT-AC68U router (that is my aim - i want to make a home storage drive, controlled from the router) - not working.

BTW, I tried to use the enclosure with my old WD Green 500GB HDD - works like a charm.


My question: is there a way for Silver River III 5G to work with 5TB WD Red HDD?


Thanks in advance.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...