Jump to content

TOUGHPOWER PF1 750w no power to mainboard


Craig110
 Share

Recommended Posts

I'm replacing a Dell OEM power supply with a TOUGHPOWER PF1 750w (Platinum) so that I can eventually add a decent-sized GPU to the system.  I ordered one from Amazon and tried it a few days ago.  (Note, I'm a computer enthusiast and professional for over 4 decades now, so swapping power supplies is something I've done many times in the past.)  Keeping the new video card out of the picture - I am a firm believer in changing just one thing at a time when possible - only two connectors are needed; an 8-pin main power and a 4-pin auxiliary power.  (The mainboard has a connector that sends power to the disks and DVD.)  Simple: Take out the old PS, prep the new cables, insert new PS, plug cables into mainboard,  confirm the cables are secure on all ends, plug into outlet, switch to "1" and hit the boot button.

Nothing.

Hmmm, ok, double-checked everything and all the connections are good, the correct half of the separated 8-pin connector is being used in the 4-pin slot, everything is oriented correctly and the cables are secure.  Try to boot again.

Nothing.

I swapped what I could to see if a cable was having problems: Swapped the power cable, confirmed I was using the same outlet as before, and swapped which of the CPU power cables was acting as the main connector.  No change.  I figured that something was amiss with the PS itself and so sent it back and ordered a replacement.  Oh, and of course my old PS powered up the system immediately upon being installed.

The replacement came in today and I just went through the process of installing it.  Hit the boot button and the system did nothing.  (Oops, started to think that the one I sent back wasn't broken after all.)  Thinking it was detecting a fault somewhere, I unplugged everything  (memory, power line to disk, fans, etc) one at a time to isolate the problem.  Nothing.  I added a Kill-A-Watt meter to the power line and confirmed that yes, the PS was drawing a few watts of power.  Put the old PS back in and the system is up and happy.

The mainboard is a Dell 0C27VV A03.  Any known issues trying to power this with a PF1 750w?  Any suggestions on what I should do next?

Thank you.

Craig

Link to comment
Share on other sites

Hello @Craig110,

Thank you for your message and we are sorry to hear that.

Here are some suggestions for you:

 - Please must install our cable on PF1 because all pin definition of power cable are not same in different supplier.

- If the system is still not working, please find your purchaser to test PSU.

- We offer 10 years warranty.

Hope this information helps!  

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...