Jump to content
Sign in to follow this  
kivaz

windows key don't work

Recommended Posts

Hi,

 

I just bought the Challenger prime keyboard

(http://www.ttesports.com/Keyboard/156/CHALLENGER_Prime/productPage.htm?a=a&g=ftr#.Vp6_2PnhCUk)

 

I've installed the software, everything runs ok (it is very slow to apply changes but I can live with that), but if I configure ANYTHING in the software and apply changes, the left windows key don't work anymore. If I turn the settings to default, it works again, but any changes I make, the problem appears again.

 

I'm on win 7 64 SP1

 

Thanks,

 

Walter

Share this post


Link to post
Share on other sites
Guest Tt Josh

Hi,

 

I just bought the Challenger prime keyboard

(http://www.ttesports.com/Keyboard/156/CHALLENGER_Prime/productPage.htm?a=a&g=ftr#.Vp6_2PnhCUk)

 

I've installed the software, everything runs ok (it is very slow to apply changes but I can live with that), but if I configure ANYTHING in the software and apply changes, the left windows key don't work anymore. If I turn the settings to default, it works again, but any changes I make, the problem appears again.

 

I'm on win 7 64 SP1

 

Thanks,

 

Walter

Hi, just for your information, you can only set macros in GAME MODE and once you're in GAME MODE, the WINDOWS KEY will automatically disabled to prevent accidentally pressed during gaming. If you want to enable the WINDOWS KEY, you will need to shift back to NORMAL MODE by pressing (Fn+PrtScr).

Share this post


Link to post
Share on other sites

Hi,

 

I just bought the Challenger prime keyboard

(http://www.ttesports.com/Keyboard/156/CHALLENGER_Prime/productPage.htm?a=a&g=ftr#.Vp6_2PnhCUk)

 

I've installed the software, everything runs ok (it is very slow to apply changes but I can live with that), but if I configure ANYTHING in the software and apply changes, the left windows key don't work anymore. If I turn the settings to default, it works again, but any changes I make, the problem appears again.

 

I'm on win 7 64 SP1

 

Thanks,

 

Walter

yea, can only be used in normal mode with macros disabled. Don't worry though, they have no intention in fixing it from what I gathered.

Share this post


Link to post
Share on other sites

yea, can only be used in normal mode with macros disabled. Don't worry though, they have no intention in fixing it from what I gathered.

 

Seriously? You mean after I got it and all this time has passed by? Like didn't we bring this up in a topic back in September 2015? It's been like 5 months now. All it takes is a simple software update as it can be coded by the software to make a profile that macros + windows key work together. A normal + gaming profile in one where the macros and windows key work.

 

Did this even get to the dev team as promised or was this a whole bunch of horse-shiit talk? And nothing was ever "escalated" as said by other users? Common man, this ####me off. Update the software and be done with it. Logitech and Razer don't suffer from this issue

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×