Jump to content

Chaser MK-I HDD Docking Station doesn't work! Help!?


Recommended Posts

I built a system with a Asus Z170 Pro Gaming motherboard.
I hooked power up the power cable for the docking station and ran the sata connector to one of my sata ports on my mother board.
The hot swap feature of the docking station isn't working. It will read the drive on a system reboot but no hot swap.

I tried sticking the sata cable into one of the sata express ports on my motherboard but that didn't work either.
The manual says to activate the AHCI function on my mother board but I couldn't find an option for that when I ran Bios, maybe it comes preset?


I am running Windows 10 Pro Full version 64 bit.


This was the main reason I chose this particular case and it isn't working. Someone please help me!? Thanks!

Link to comment
Share on other sites

hi JuggaloCujo,


under your integrated peripherals/sata settings you will find the settings per sata port.   there will also be a setting for "HOT SWAP" which will have to be enabled or the hot swap function will not work at all.


I recommend starting the PC with the drive in the top drive bay so its easier to identify which port it is as ASUS BIOS normally shows the drive name of a installed storage device for each port.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...