Jump to content

Black V2 Not responsive

Albert Ender

Recommended Posts

Hi All,

I need help with thermaltake Black V2 mouse.

I am not sure what is the problem with it.

In most cases when I start the PC mouse does not response but sometimes is working ok.




MB : gigabyte G1.SNIPER.M5

CPU: i7-4790k

OS: Windows7 Ultimate 64bit



I installed the Tt eSPORTS Command Center V1.018.exe

My suspicious is it tried to install a firmware then give an error

I removed and Installed the previous version of software TteSports_BlackV2_GUI.exe



If not responsice I plugout the usb cord from the back panel of PC for several seconds then plugin

then works

The usb mouse is not supposed to be like this


I need urgent help

Link to comment
Share on other sites

I have official Thermaltake Black v2 mouse

I have been downloaded all kind drivers from thermaltake  official site.

Now you gave me so unknown site url.

For security reasons I can not do this.

I am expecting solution from thermaltake and from official site of it.

Thank you for your help David but you have to understand me.


So until now I did not received help.

I have been bought a lot of equipment from thermal take I did not looked for help but this scale shows me and started to change my opinion about thermaltake.

I opened this ticket long time ago until no solution.

I am very disappointed of you (thermaltake)


Why do not ask gigabyte.

motherboard & bios from gigabyte G1.sniper.m5 . while entering BIOS it is not respond.

May be start looking a solution  at this point.


My second PC:

By the way I have G1.sniper.m3 board and the same mouse another rig the same problem too.

Shortly your mouse not recognizable by bios for 100%

Waiting focused answers and fast.


Link to comment
Share on other sites

  • 5 months later...

Hi again

It passed several months from my problem still no solution.

I tried everything that suggested here but I my problem still remains as titanium


Frankly I am very disappointed from thermaltake .

I have 2 thermaltake BlackV2 mouse and other brands like Logitech Gamer mouse and not gamer mouse

All mouses are working fine except thermaltake BlackV2 mouses.


I want to give a change may be thermaltake will solve my problem otherwise I have to disbanded all thermaltake products from now and to the future.

for example I have 3 chases , a lot of fans from thermaltake too


Dear Sir David,

You tried several things for solving the problem.

What can I do if my mouse does not move how  can I click right or left???

Link to comment
Share on other sites

Hi Albert,


Here is some advice for this case:


1. Could you please try it on the other computer and check if it can work or not? If it doesn't work either, please contact our customer service:


USA / Canada :


Tel: Toll-Free 01-800-988-1088

M-F 9:00AM â€“ 5:30PM (P.S.T)   


Brazil: suporte@thermaltakebr.com


Asia: cs2@thermaltake.com


Europe:  support@thermaltake.de


2. If it works, please reinstall the software: http://www.ttesports.com/files/Product_download/ttesportscommandcenterv1.0243.zip


1. plug out your mouse

2. remove software

3. go to C:\Program Files (x86)\TteSPORTS and clean all files

4. restart your computer

5. plug in the mouse (use USB 3.0 port if possible)

6. install software

Link to comment
Share on other sites

  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...