Jump to content
Sign in to follow this  
gedy

cronos ad

Recommended Posts

I recently bought the cronos ad headset and when I say recently i mean yesterday it arrived

i opened the package this morning plugged them in and they didn't work

what should I do?

by the way I have set them to default,I updated drivers,I tried to disable and enable them,I even restarted my computer,I replugged them in 

The only thing i can think of is either a) the headphones are broken 

                                                          b my computer is broken

Edit: I think its from the headphones i plugged them in my phone and they still didn't work

Share this post


Link to post
Share on other sites

Could you try it on the other computer?

 

If it doesn't work, please contact our customer service: http://my.ttesports.com/csWarranty.aspx

 

USA / Canada :

ttsupport@thermaltakeusa.com

Tel: Toll-Free 01-800-988-1088

M-F 9:00AM â€“ 5:30PM (P.S.T)   

 

Mexico :

Por Email: apoyotecnico@thermaltakeusa.com

Por Telefono: 01-800-823-2606

En el D.F: (55)5648-6715 Atencion de 10:00AM a 6:00PM (P.S.T)   

 

Brazil: suporte@thermaltakebr.com

 

Asia: cs2@thermaltake.com.tw

 

Europe:  support@thermaltake.de

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...