Jump to content

Posidon Z RGB Not Working After Firmware Update


Recommended Posts

TT Team and Members,


I just bought my Poseidon Z RGB today and tried to update the firmware. The software prompted that I was running version 30 and asked if I wanted to update to firmware 48, so I did. After updating, my keyboard isn't functioning anymore even after multiple reboots and plug in and outs of different USB ports.


Tried to update the software and it says I'm running Version 0 as seen in the attached snip. I've tried to update multiple times but to no avail.


Please advise.





Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...