Jump to content
Sign in to follow this  
NINtoolLICA

Cronos RGB 7.1 loud humming noise when lights are on

Recommended Posts

I just bought my Cronos RGB 7.1 headset and really like the quality, but when I activate the lights, there is a loud humming noise in time with the lights settings (Spectrum Running, Pulse Jumping, and Static). Is this supposed to happen? If so, is there a way to turn it off so that you have the lights without the annoying humming noise?

Share this post


Link to post
Share on other sites

Could you please contact our customer service and we will have someone arrange the new version for you:

USA / Canada :

ttsupport@thermaltakeusa.com

Tel: Toll-Free 01-800-988-1088

M-F 9:00AM - 5:30PM (P.S.T)   

Mexico :
Por Email: apoyotecnico@thermaltakeusa.com
Por Telefono: 01-800-823-2606
En el D.F: (55)5648-6715 Atencion de 10:00AM a 6:00PM (P.S.T)   

Brazil: suporte@thermaltakebr.com

Asia: cs2@thermaltake.com

Europe:  support@thermaltake.de

Australia
TEL : +61 (03) 9544 6587 
E-MAIL :sales@thermaltake.com.au 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...