Jump to content

Level 10M (wired) freezes


Recommended Posts

Hey, folks. I'm encountering a weird issue that just started happening earlier today.

 

Every so often, my mouse will freeze and not respond to any movements or clicks for a few seconds. Then, it will suddenly jump to where it should've been had it actually responded quick enough. What's weird about this is that the software seemed to restart when this happened. I did a virus scan and that showed nothing. I tried different USB ports and got the same issue. Nothing new was installed before it started happening. It just started to do it randomly. I've had this mouse for a little over 8 months, I believe, and I've never had this issue. Any help? Has anyone else had this issue?

Link to post
Share on other sites
Guest Tt Paul

Hey, folks. I'm encountering a weird issue that just started happening earlier today.

 

Every so often, my mouse will freeze and not respond to any movements or clicks for a few seconds. Then, it will suddenly jump to where it should've been had it actually responded quick enough. What's weird about this is that the software seemed to restart when this happened. I did a virus scan and that showed nothing. I tried different USB ports and got the same issue. Nothing new was installed before it started happening. It just started to do it randomly. I've had this mouse for a little over 8 months, I believe, and I've never had this issue. Any help? Has anyone else had this issue?

Hi, Gabene

 

Welcome to Tt Community.

 

Please provide us Product serial No. and let us know which country are you from, thank you.

 

Sorry for the inconvenience. 

Link to post
Share on other sites
Guest Tt Josh

I've not tried that yet. I'll give it a shot.

EDIT: S/N: MO-LTM0091212003249 USA

Hey Gabene, try to reinstall the firmware and if you're still facing the same problem, tell us and we'll look into the matter for you!  ;)

Link to post
Share on other sites
Guest Tt Josh

Tried all that and I'm still having the same problem. It really doesn't make sense that it would happen now after I've had it for 8 months. Especially when virus scans came back clean. MWB and Panda both said nothing.

Hey Gabene, sorry for the late reply.

 

Please try with another desktop/laptop just to test whether it works on another desktop/laptop.

 

If the problem still occurring, tell us again and we'll assist you further!  ;)

Link to post
Share on other sites
  • 11 months later...
Guest Tt Josh

Please help me i have the same problem . 

 

2 weeks ago i bought a Level 10 M wireless Mouse, 

 

when i tried to use the wired conection "not respond to any movements or clicks"   when i tried to use the mouse (wired mode) in other pc i can't not respond . 

 

please tell me the solution .

Hi, which country are you from? 

 

Did you try to install the software from our website? Here's the LINK

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...