Jump to content
  • Forum Statistics

    3,342
    Total Topics
    28,160
    Total Posts
  • Member Statistics

    124,451
    Total Members
    16,800
    Most Online
    uspassport13
    Newest Member
    uspassport13
    Joined

bobbl

Members
  • Content count

    3
  • Joined

  • Last visited

About bobbl

  • Rank
    Beginner
  • Birthday August 23

Profile Information

  • Gender
    Male
  • Location
    Canby, OR
  • Interests
    Duh! Computer Enthusiast!
  1. Gurgle, gurgle, gurgle...

    I have the 3.0 Extreme, and it has been working GREAT! I use it in a push/pull configuration. Today, I swapped out the fans (all the exterior facing ones anyway) with the White LED Riing 120's. I absolutely love them, and the system looks awesome. But after installing them, and putting the system back together. I turned it on only to here water gurgling in the system. After about 15 minutes, it finally went away. IS THIS A NORMAL THING FOR THE CHANGE I MADE? Or, should I be concerned about this? Just curious.
  2. Water 3.0 Series owners club

    I'm new to this forum, so shoot me if this is the wrong place to ask this! I have the 3.0 Extreme, and it has been working GREAT! I use it in a push/pull configuration. Today, I swapped out the fans (all the exterior facing ones anyway) with the White LED Riing 120's. I absolutely love them, and the system looks awesome. But after installing them, and putting the system back together. I turned it on only to here water gurgling in the system. After about 15 minutes, it finally went away. IS THIS A NORMAL THING FOR THE CHANGE I MADE? Or, should I be concerned about this? Just curious.
×