Jump to content
  • Forum Statistics

    3,070
    Total Topics
    27,037
    Total Posts
  • Member Statistics

    123,608
    Total Members
    16,800
    Most Online
    Westfall
    Newest Member
    Westfall
    Joined

Willem

Members
  • Content count

    5
  • Joined

  • Last visited

  1. **ATTN Users with Thermaltake Riser Cables**

    This is basically what we all suffer from. It's been over a month since I got a reply so I went out and bought the premium version (TT Charge 191$) Of an Ebay seller. Sure enough, works fine. Until 2 weeks passed, then the same #### happened again. Going with a different brand now.
  2. **ATTN Users with Thermaltake Riser Cables**

    And? Did it work?
  3. **ATTN Users with Thermaltake Riser Cables**

    Update: Riser cable failed again. Sent another email. Tried to order the premium one online because im sick of this **** right now. Guess what?! ''We are happy to offer international shipping services'' Grand total for the $69 cable you ask? $191. Id happily pay for the premium one if it solves the issue, but this is just borderline stupid.
  4. **ATTN Users with Thermaltake Riser Cables**

    UPDATE: Received my new riser cable today, installed it and tested it. So far it's not causing any problems. *Fingers Crossed* The cable I received -> None of the above actually. It's sort of the cheap one, with a different lock and no thermaltake branding what so ever... What I did notice was the black top layer is pasted on with adhesive, which came off straight away with the smallest amount of bending. (installed the cable in my core P3, and both ends have the black end parts loose reveiling the cable underneath, not sure if this will cause problems but I feel it's cosmetic at this point). Will keep you updated if anything changes. Special thanks to @ThermalMike for his quick replies, really sped up the process.
  5. **ATTN Users with Thermaltake Riser Cables**

    I'm having the same issues, sent an email, no reply yet so I'm trying it here.
×