Jump to content

Search the Community

Showing results for tags 'z'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Thermaltake
    • Enthusiasts
    • Chassis
    • Power Supplies
    • Cooling
    • Storage
    • Accessories
    • General Discussion
    • Events
    • FAQ
  • Tt eSPORTS
    • Tt eSPORTS PLUS+ Community & Data Management Platform
    • Gaming Mice
    • Gaming Keyboards
    • Gaming Headsets
    • Gaming Controller
    • Gaming Mouse Pads
    • Gaming Accessories
    • Team Tt eSPORTS
    • Tt eSPORTS Streamers
    • Gaming Chair & Gaming Station
    • Tt eSPORTS General Discussion
    • Tt eSPORTS Events
    • Tt eSPORTS FAQ
  • LUXA2 Thermaltake Mobile
    • Power Bank Solution
    • Holder Solution
    • Audio Solution
    • Accessories
    • LUXA2 General Discussion
    • FAQ
  • Others
    • Off Topic
    • Customer Service

Categories

  • Thermaltake
  • Tt eSPORTS
  • LUXA2
  • Others

Calendars

  • Community Calendar

Blogs

  • Thermaltake
  • LUXA2
  • Tt eSPORTS

Found 2 results

  1. Hi! I own a Ventus Z mice, with the Avago sensor, pretty nice sensor it feels like an optical in all regards, I have the mouse for 6 months as my main for gaming. However, days a go, while I was in a middle of a game the sensor stop working, wasn't responding and stuck in a jitter. I didn't know what happen, so I unplugged and plug back in, the problem keeps happening, so I tap around the sensor lens (no directly) and start to work again. I play at 3900 dpi, but very low ingame sensitivity so I pick up the mouse from the pad quite often. After this incident, happen again and fix it with the same knocking with the finger tips around the sensor... then however I felt like the dpi sensitivy has changed. So, I went to the Commander Software and the sensitivity was still at 3900 but it felts very sluggish, I have to ramp up to 4300 to have the same 360 turn on FPS games, meaning the same sensitivity/control before the sensor issue. There is no sensor rattle I can hear on the mouse. Any help support will be much appreciated.
  2. Hi y'all, First of all, this is my first mechanical keyboard so I'm really excited that this one was on sale at MicroCenter and I was able to get the last one. I downloaded the most recent software for the Poseidon Z RGB from the ttesports website, and when I open it up it looks fine. Yet, when I make any change to a profile, like changing a color on static mode, and then hit apply, it shuts off the LEDs on my keyboard and basically makes every single key on my keyboard unusable, as if it was unplugged. I would have to unplug and plug my keyboard back into my PC in order for the LEDs to come back on and for me to be able to use the keyboard. I'm not sure whether it's an issue with the software or an issue with my keyboard, because if I leave my keyboard with the preset profiles on it, it will work fine. Any help would be great, thanks.
×