Jump to content
dvanteb

CHALLENGER PRIME Problems

Recommended Posts

Hi, this issue has already been brought up by a lot of our fans our there and it has already been passed to the appropriate team. The team will look into it accordingly.

When will it be fixed? 

Share this post


Link to post
Share on other sites
Guest Tt Josh

When will it be fixed? 

We will need to wait for the appropriate team to inform us about the news. For now, game mode will disable the windows key.

Share this post


Link to post
Share on other sites

We will need to wait for the appropriate team to inform us about the news. For now, game mode will disable the windows key.

This problem was first reported over a year ago you are bullshitting and nothing is coming.  Going to return my keyboard after work tomorrow

Share this post


Link to post
Share on other sites

Well this thread made me sad (Game Mode vs Windows Mode).

 

I got this "gaming keyboard" to use outside of gaming. Would never have thought that such a bad design choice would be made. Macros are not only a gaming thing.

 

Whenever there is "one or the other" usually this can be solved with "Why not both?"...

 

I have a "gaming mouse" that doesn't differentiate if you are in a game. BUT the good news is there are other "gaming keyboards" that don't take such a myopic view on this.

 

Really hope that this gets patched...

Share this post


Link to post
Share on other sites
Guest Tt Josh

Well this thread made me sad (Game Mode vs Windows Mode).

 

I got this "gaming keyboard" to use outside of gaming. Would never have thought that such a bad design choice would be made. Macros are not only a gaming thing.

 

Whenever there is "one or the other" usually this can be solved with "Why not both?"...

 

I have a "gaming mouse" that doesn't differentiate if you are in a game. BUT the good news is there are other "gaming keyboards" that don't take such a myopic view on this.

 

Really hope that this gets patched...

Thanks for the feedback. We are currently working to fix the problem for you guys as many of you brought up the same issue, sorry for the inconvenience. :)

 

We will provide you guys the update when we have more information on that.

Share this post


Link to post
Share on other sites

I only registered to +1 this. I RMA'd my board thinking the Windows Key was busted, but then had this happen again and figured it couldn't be two boards. This re-enabled the left windows key not working.

 

Thanks for the contrib.

 

 

I had the same issue when I got this keyboard. The reason this has occurred is the keyboard is in game mode. Apparently, when in game mode, the windows key is disabled. The fix is easy, just put the keyboard back into normal mode. This can be accomplished by holding down the (Fn) button, then pressing the (PrtScr/SysRq) button, just to the right of the F12 button. Now your windows key should be active. Hope this helps.

Share this post


Link to post
Share on other sites
Guest Tt Josh

We are currently working on having windows key enabled while in game mode, we will provide you guys further information when it's ready. :)

Share this post


Link to post
Share on other sites

So, I tried running the setup, and when you choose the setup folder, it won't let me continue. The setup window gives an error, reading "String ER_Create_Reg was not found in string table." After I click OK on that, another error pops up, reading "ER_Create_Reg" and when I click OK, setup crashes. How do I get around this or fix it?

Share this post


Link to post
Share on other sites
Guest Tt Josh

So, I tried running the setup, and when you choose the setup folder, it won't let me continue. The setup window gives an error, reading "String ER_Create_Reg was not found in string table." After I click OK on that, another error pops up, reading "ER_Create_Reg" and when I click OK, setup crashes. How do I get around this or fix it?

Here's the current software: CHALLENGER PRIME GAMING SOFTWARE VERSION 3.0

Share this post


Link to post
Share on other sites

yes in highest setting (100% in the software also) in normal mode is less brighter then in gaming mode (also in highest setting).

Is there any problem? should i clame it in rma? Pls help

 

Try Fn+Pause/Break (it changes color) -- when it changes back to your chosen color, it should be in full brightness, at least mine did that.  Hope this helps.

Share this post


Link to post
Share on other sites

Hey Josh, C'mon, what the #### is going on? Its been like 2 #### #### years. Could your dipshit devs open source the code so someone competent can unfuck it please? Really unhappy with you #### blossoms.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×